Upgrade to VM Pro from GPL Fails - Ubuntu 22.04

SYSTEM INFORMATION
OS type and version Ubuntu 22.04.1
Virtualmin version VM7

Page Output:

Creating Virtualmin license file …
… done

Updating available packages …
… failed

Hit:1 http://us.archive.ubuntu.com/ubuntu jammy InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu jammy-backports InRelease [99.8 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Ign:5 https://software.virtualmin.com/vm/7/apt virtualmin InRelease
Err:6 https://software.virtualmin.com/vm/7/apt virtualmin Release
  404  Not Found [IP: 163.172.162.254 443]
Hit:7 https://ppa.launchpadcontent.net/ondrej/php/ubuntu jammy InRelease
Reading package lists...
E: The repository 'https://software.virtualmin.com/vm/7/apt virtualmin Release' does not have a Release file.

Upgrading to Virtualmin Pro …

Failed to upgrade to Virtualmin Pro : No packages to install found!

I assume this has something to do with Ubuntu 22.04 only being supported by the beta installer, but setup the solution, moved all my sites to it, liked it… so I paid for it, and just trying to get those shiny new features.

Please let me know what I need to do to correct this!

@exactit,

I’d definitely recommend sending a “private message” to @staff as it could be a bug, and/or because you are trying to upgrade to a paid service, it will be a priority matter.

*** Professional, Affordable, Technical Support https://tpnassist.com ***

maybe the server was down when you tried, try again
ping software.virtualmin.com

Pinging software.virtualmin.com [163.172.162.254] with 32 bytes of data:
Reply from 163.172.162.254: bytes=32 time=308ms TTL=45
Reply from 163.172.162.254: bytes=32 time=308ms TTL=45
Reply from 163.172.162.254: bytes=32 time=309ms TTL=45
Reply from 163.172.162.254: bytes=32 time=309ms TTL=45

Ping statistics for 163.172.162.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 308ms, Maximum = 309ms, Average = 308ms

Hello,

This is a known issue which will be fixed in upcoming Virtualmin 7.2 release. Sorry about now.

The easiest and cleanest way to fix it for now is to grab Virtualmin 7 pre-release install script and use it to setup repos and exit, i.e.:

wget -O virtualmin-install-pre-release.sh https://raw.githubusercontent.com/virtualmin/virtualmin-install/d7fcb4ea35b5545417a38b7af4c4d97dbe45d591/virtualmin-install.sh
sh virtualmin-install-pre-release.sh --setup

… and then run apt-get upgrade to upgrade to VIrtualmin Pro.