Upgrade to pro not working

OS type and version Ubuntu 20.04
Webmin version 1.991
Virtualmin version 7.0-4
Related packages SUGGESTED

@staff upgrade to Pro isn’t working.

Although I have 7.0-4 running now, when I had 6.x it also didn’t work.

The only clue I have is I started off with Pro, which worked for a long time. Then when the licensing server bombed I downgraded to GPL. I believe somewhere along the lines this is where it went wrong, but it’s too long ago so I can’t remember.

See the screenshot. Pro features still not enabled, even after logging in and out. Please help?


There was a bug unfortunately in upgrade.cgi which will be fixed in Virtualmin 7.0.0-6 pretty soon.

Meanwhile what is the output of:

cat /etc/apt/sources.list.d/virtualmin.list

Hi there, thanks so much for the reply. The output is:

/root]> cat /etc/apt/sources.list.d/virtualmin.list
deb http://xxxxxxx:xxxxxx@software.virtualmin.com/vm/6/gpl/apt virtualmin-focal main
deb http://xxxxxxx:xxxxxx@software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main

@Ilia just tagging you so long. When I compare those values to my shop license, it appears different. Also perhaps this is confidential info, I should probably mask it? :slight_smile:

Yes, you should never share active license details in public posts! Although, that was an expired license, not a big deal then.

Go to your Virtualmin.com -> My Account find your active license and copy to the clipboard the change license command and execute it on your server. Afterwards, upgrading to Pro must work.

This is what I get:

> virtualmin change-license --serial xxxxxxx --key yyyyyyyy
GPL repos detected. Use `System Settings ⇾ Upgrade to Virtualmin Pro` in UI instead to upgrade first!

Updates the Virtualmin Pro license for this system.

virtualmin change-licence --serial number
                          --key id

So basically I’m back to where I started. I’m guessing I need to specify Pro repos, but I have no idea!

You didn’t downgrade properly in the past.

The simplest solution to fix repos on GPL systems would be downloading and running install.sh -s script (note with -s flag).

1 Like

FANTASTIC!! Thanks so much, that worked :smiley:

I’m so happy, I really love your product so much!


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.