Upgrade to php 5.3?

Currently running PHP Version 5.2.17 on Operating system CentOS Linux 5.10
Webmin version 1.690 Virtualmin version 4.08.gpl GPL and need to upgrade to PHP Version 5.3 can anyone advise how I do this?

Howdy,

One way to do that would be to migrate to a new server, running a new distribution, as described in your post here:

https://virtualmin.com/node/33436

Another way is that, beginning in CentOS 5.6, they provide PHP 5.3.3, which you can install in place of your current PHP version.

You can see those packages by running “yum search php53-”.

What you would need to do is remove your existing “php-” packages, and in their place, install the corresponding “php53-” packages.

-Eric

Thanks for that, is there any way I can get 5.3 on my current setup migration sounds like a lot of work?

Howdy,

Well, using PHP 5.3 on your current setup is described in the second half of my post above… take a peek at that (starting at where it says “Another way is that, beginning in CentOS 5.6”) and see if that will work for you.

-Eric

Sorry thanks Eric

Sorry to be so dumb which should I pick which is the full distro of php53

yum search php53-

Reducing Red Hat Enterprise 5 - x86_64 - Virtualmin Bleeding Edge to included pa ckages only
Finished
=============================== Matched: php53- ================================
php53-bcmath.x86_64 : A module for PHP applications for using the bcmath library
php53-cli.x86_64 : Command-line interface for PHP
php53-common.x86_64 : Common files for PHP
php53-dba.x86_64 : A database abstraction layer module for PHP applications
php53-devel.x86_64 : Files needed for building PHP extensions
php53-gd.x86_64 : A module for PHP applications for using the gd graphics
: library
php53-imap.x86_64 : A module for PHP applications that use IMAP
php53-intl.x86_64 : Internationalization extension for PHP applications
php53-ldap.x86_64 : A module for PHP applications that use LDAP
php53-mbstring.x86_64 : A module for PHP applications which need multi-byte
: string handling
php53-mysql.x86_64 : A module for PHP applications that use MySQL databases
php53-odbc.x86_64 : A module for PHP applications that use ODBC databases
php53-odbc64.x86_64 : A module for PHP applications that use ODBC databases via
: unixODBC64
php53-pdo.x86_64 : A database access abstraction module for PHP applications
php53-pgsql.x86_64 : A PostgreSQL database module for PHP
php53-process.x86_64 : Modules for PHP script using system process interfaces
php53-pspell.x86_64 : A module for PHP applications for using pspell interfaces
php53-snmp.x86_64 : A module for PHP applications that query SNMP-managed
: devices
php53-soap.x86_64 : A module for PHP applications that use the SOAP protocol
php53-xml.x86_64 : A module for PHP applications which use XML
php53-xmlrpc.x86_64 : A module for PHP applications which use the XML-RPC
: protocol

Is it yum install php53-common.x86_64

Howdy,

If you run this command:

rpm -qa | grep php-

You’ll see all the PHP 5.2.17 packages that you currently have installed.

What you would want to do is replace each one of those, with a corresponding php53- package.

You would need to remove those php- packages, and then replace them with the php53- packages.

-Eric

Thanks for this, I have installed…

# rpm -qa | grep php- wbm-php-pear-1.5-1 php-cli-5.2.17-1.el5.vmbleed php-mbstring-5.2.17-1.el5.vmbleed php-xmlrpc-5.2.17-1.el5.vmbleed php-pdo-5.2.17-1.el5.vmbleed php-5.2.17-1.el5.vmbleed php-devel-5.2.17-1.el5.vmbleed php-gd-5.2.17-1.el5.vmbleed php-snmp-5.2.17-1.el5.vmbleed php-mysql-5.2.17-1.el5.vmbleed php-pear-1.8.0-1.el5.vm php-mcrypt-5.2.17-1.el5.vmbleed php-common-5.2.17-1.el5.vmbleed php-odbc-5.2.17-1.el5.vmbleed php-pgsql-5.2.17-1.el5.vmbleed php-imap-5.2.17-1.el5.vmbleed

When I compare against the yum search php53- results shown above there isn’t an alternative 5.3 version for:

wbm-php-pear-1.5-1 php-5.2.17-1.el5.vmbleed php-pear-1.8.0-1.el5.vm php-mcrypt-5.2.17-1.el5.vmbleed

What should I do?

Howdy,

The first three shouldn’t be a problem… however, RHEL/CentOS doesn’t provide an “mcrypt” module. So that’s something that won’t be there when you update.

So before you upgrade, you’d want to determine if any of your applications rely on the PHP mcrypt module.

-Eric

OK in case it’s useful to others I’ve managed to upgrade to PHP 5.3 using this guide:

http://www.rackspace.com/knowledge_center/article/how-to-installupgrade-php-53-for-centos-5x