Upgrade PHP

I’m pretty sure that Drupal 6 runs fine under PHP 5.1.x. I even tested it some for a while on our new website. There are a couple of pretty popular modules that do require 5.2.x, though. But, I’d probably check to be sure you need it before making the switch. (Though I doubt there will be any compatibility problems going forward.)

right, it was the Drupal installation FAQ that recommended the upgrade of PHP… the issue is: will it break other apps on the server? XOOPS and Zencart in particular… I’m checking on those sites.

Our ecommerce site admin is traveling and PHP 5.2.9 will break ZenCart until we upgrade ZenCart first (sessions algorithms have changed) so I have to wait til he gets home later this month and we upgrade ZenCart.

Meanwhile we are running all the PHP extensions listed by Drupal’s FAQ except this one:


Does anyone know what this one does and how to install it? Can we install PHP extensions like this from inside VirtualMin? If it is automatic on upgrade to PHP 5.2.9 then I will wait. But, I’m a PHP infant and I’d just like to understand it… www.php.net manual wasn’t very helpful. and a Google search for pxs2 doesn’t get me anything but more unclarity. I assume it’s some kind of lib that is called on install and compiled in with the rest… Do we need to install that lib before we upgrade to 5.2.9? Where? in the /use/include/php/ext/ (I don’t see any lib that matches “pxs2” in there now…) Or can we just drop the lib in a directory, add a line in the php init/config and restart apache?

If this is not the place to hold out begging bowls for PHP mentoring or edu then fire away and tell me where to go :slight_smile:

(a url would help since I can’t find it on PHP.net)

Is it possible it was "apxs2" rather than just "pxs2"?

The apxs2 option is what is needed to compile PHP as an Apache module, which I believe is essentially "mod_php".

That said – I do not believe Drupal as a whole requires mod_php, so I’m not sure what to make of all that :slight_smile:

There is no --with-pxs2 option. As Eric mentioned, there is --with-apxs2, and it is compiled into every version of PHP you’ll get with any modern Linux distro (on very old distros you might get --with-axps, instead, which is for Apache 1.x).

I don’t think you need to worry over apxs2, at all.

OK I;m happy to let it go, but the developers of the new site on our server who are not so savvy will ask "what are we to make then of Acquia Drupals recommendation to have

with-pxs2? on the system?


http://acquia.com/node/276984 is the recommendation "bogus"

php.info does not list "with-apxs2" and the server API is set to Fast CGI.

Meanwhile, I’ll tell them not to worry about it, that it is “compiled” into it on installation and as such does not need to be called from an external lib… right?

There were three posts on the second page begging for documentation on how to use the repository. Can somebody please answer?



Everything you should need in order to use it should be here:


That includes an explanation of what it is, who should use it, as well as how to setup the repository :slight_smile:

Once you’ve followed the instructions in the above docs (of note, be sure to install the virtualmin-bleed-release package), updating to the version of PHP in that repo should just be a matter of running a “yum update”.

http://acquia.com/node/276984 is the recommendation "bogus"

It’s a typo. Then again, they also recommend with-pgsql, which nobody uses for Drupal (though Drupal will mostly run on PostgreSQL in recent versions). So, bogus is seeming more likely by the minute.

Drupal runs just fine under mod_fcgid or mod_php. I don’t what to tell you. If your developers can’t look at a Drupal site running fine on the system, and understand that it is working fine, I don’t think your or I can fix that. :wink: