Upgrade from Virtualmin gpl to Virtualmin pro and nothing changed

Hi I have been working though Webmin & Virtualmin this last couple of weeks (I’m on holiday) so that I can self host some websites. So far everything has been relatively easy (considering this is all on a Raspberry Pi 3 so I had to install everything manually) until today. Today I purchased a Virtualmin Pr 10 license, went to system settings > Upgrade to Virtualmin Pro, put in the relevant details and clicked on Upgrade Now. Virtualmin then went through and created the files and updated apt.

I then went to check if the list of install scripts had increased but there were only 7, instead of the 100+ I was expecting, available. I rebooted my Pi logged back in and still no change.

Is there something I am missing here?

Thanks in advance.


Yeah, it doesn’t sound as if the upgrade worked properly for some reason.

Would it be possible to attempt the upgrade again, and then share the output you receive with us?

Note that the Virtuallmin staff may not see your post here as quickly as in the Support tracker… my suggestion might be to open a new support ticket using the ticket tracker, and share that output there.



Hi Eric
Thanks for your speedy response. I’ll follow your advice now and if it doesn’t work this time I will open a ticket in the support tracker. I will also post here if it works and if it doesn’t work to let you know I have started a ticket.

I have created a ticket because the 2nd attempt has not worked.