Updating roundcube 1.4.9 > 1.4.11 "failed dependencies"

Debian 10, Apache 2.4.38, PHP 7.3, php-fpm, Virtualmin 6.16

I was trying to upgrade roundcube, but the upgrade process through “Update selected scripts” fails with

Upgrading RoundCube to version 1.4.11 ..
.. failed dependencies : Could not work out exact PHP version

I have only one PHP version installed.
The “Re-Check Configuration” function doesn’t show any errors and otherwise the system has been working fine from the beginning.

Does someone have any pointers on how I could fix or work around this issue?

Which exact PHP version do you use? Is there a specific reason not to upgrade to the latest version from the PHP 7 branch?
Did you edit/change something manually at the PHP versions?

7.3.27
This is from the stable branch of Debian Buster, so it gets regular security updates and that’s also why this version is used.
I did not change any PHP related things, this is basically a Debian Buster vanilla installation which runs smoothly, with the exception of upgrading roundcube.

Just asked out of interest. Did you check the log files?

@deepthought will this fix an issue on your side if you re-run config check and/or go to virtual-server.name - Server Configuration ⇾ PHP Options and either change PHP execution mode or PHP version and try again upgrading RoundCube script afterwards?

@Ilia I’ve tried all available PHP execution modes (mod_php, CGI wrapper, FCGId and FPM) and running the config check again. All yields the same results as before when trying to upgrade Roundcube.
I’m unable to change the PHP version in Virtualmin (there’s only one version installed).

What if you go to virtual-server.name - Edit Virtual Server page and first disable Apache Website and Apache SSL Website as a feature, save and then re-enable it?

Before doing the above, please backup /etc/webmin/virtual-server, /etc/php and /etc/apache2 directories, because if mentioned above work-around works for you, I would like to have a look at the content of those directories before and after the change to understand what’s causing it.

@Ilia I did that but I still get the same error message when trying to upgrade Roundcube, so unfortunately this wasn’t the solution.

Is PHP-FPM service running? Try figuring out the service name by running systemctl | grep fpm and then running systemctl status php-fpm.service-name to get its status.

I’m unable to change the PHP version in Virtualmin (there’s only one version installed).

Have you tried switching PHP mode to FCGId, for example? I would suggest creating index.php file in public_html directory with the following content:

<?php
  phpinfo();
?>

… and trying opening it from the browser to see if your PHP really works.

root@v0:~# systemctl | grep fpm
  php7.3-fpm.service  loaded active running   The PHP 7.3 FastCGI Process Manager                                            
root@v0:~# systemctl status php-fpm.service-name
Unit php-fpm.service-name.service could not be found.

I will try the other suggestion later (though roundcube works, so I’m concluding that PHP also is functioning).