Update Virtualmin impossible due to shared-mime-info


Operating system Debian Linux 7.7
Webmin version 1.921
Usermin version 1.771
Virtualmin version 6.08

When I try to update webmin and usermin I have this:

Reading package lists…
Building dependency tree…
Reading state information…
The following extra packages will be installed:
The following NEW packages will be installed:
The following packages will be upgraded:
usermin webmin
2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.3 MB of archives.
After this operation, 3576 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
E: There are problems and -y was used without --force-yes

I am concerned because og this : Webmin versions below 1.930 contain a remotely exploitable security hole and should be upgraded immediately

What can I do?

Best regards


Did you start here before installing and update?
https://www.virtualmin.com/os-support.html i think this is also for webmin and usermin

Debian 8 and 9 on i386 and amd64


for various and numerous reasons I can’t update the OS. I just want to kow if it is possible to force the shared-mime-info on a debian 7.7 and if it is safe.

Best regards Robert54

Sorry don’t know .

But better be prepared for next upcommming webmin virtualmin update , expect again some bigger changes while debian 10…


I haven’t found another topic in this forum with the same problem. Maybe I am the only one. Here (http://www.webmin.com/security.html) there is an alternative:

“…if running versions 1.900 to 1.920, edit /etc/webmin/miniserv.conf, remove the passwd_mode= line, then run /etc/webmin/restart.”

But first my webmin version is 1.921, and Ichecked the passwd_mode= has always been 0.

Maybe I am safe for now.

Regards Robert54

Robert, I’m in the same situation.
I cannot upgrade my Wheezy and my Webmin version is 1.921 which I cannot upgrade either because of the uninstalled and uninstallable “shared-mime-info” .

Did you manage to solve it?



sorry for the delay, and happy new year,
but to answer the question: no I have not find a solution.
I am still looking for, but I am more and more anxious about it.


Hi guys, well debian 7 - I think its not supported any more… please consider fresh install to latest distro debian 10 which is latest stable release then every 4 years just upgrade with source list to newer distro, but do not leave it to fall behind obsolete - since 7 lot of changes happen to apache also , php, mysql etc… a lot. There is only two way solution, you get stuck or you upgrade. sorry about this. :fearful:

1 Like

oh and happy new year to you too guys.

Debian 7 has been unsupported (by Debian, not just us) since early 2018. You cannot safely run Debian 7 on a server. It is entirely unmaintained. You need to move to a new server running Debian 10 (or upgrade the current on) or some other new and supported distro immediately.

1 Like