Update theme to latest

Operating system: linux
OS version: debian9

Error - Perl execution failed

Undefined subroutine &main::authentic called at /usr/share/webmin/authentic-theme/index.cgi line 12.

i updated theme…coudnt get in my webmin, anyone know how to downgrade


You shouldn’t ignore warning messages upon theme upgrades – the latest version of the theme has Webmin 1.970 set as a dependency. The work-around would be is to downgrade the theme to the previous version by running the following command:

cd /usr/share/webmin
bin/webmin update-devel --product webmin --theme 19.62

Note: Previous command will work only with yet unreleased Webmin 1.972+, unless this patch is applied manually.

All users at the moment who is willing to downgrade the theme to the previous version, could use:

cd /usr/share/webmin/authentic-theme
./theme-update.sh --release:19.62 --force

Another option is to install latest development version of Webmin (currently 1.971):

wget https://download.webmin.com/devel/deb/webmin_current.deb
apt-get install ./webmin_current.deb

Hi there, thanks for repsonding to my post…these options do not happen to work because i did ignore these messages by updating the theme, so i removed wemin and reinstalled webmin and virtualmin rpm from virtualmin repo. After updating everything seems to working normally again…but it did not count the existing domains from previous install, is there a way to add them again to virtualmin or do i have to add them manualy??

You can just import the existing virtual server (domain) using Add Servers > Import Virtual Server feature.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.