update nss 3.21 does not show as version in cURL

Today I received the note: nns updates available: version 3.19 to 3.21
Performed the update, no errors

Though when doing this

$ curl -V

It still shows 3.19…

checking installed versions through virtualmin/webmin shows 3.21

Did I miss some important part here?

Running Centos 6.7 all latest versions of Webmin/Virtualmin


I believe the curl command just showing which libraries it was compiled against, not the libraries that are currently installed.

You may want to try running “yum update” on the command line, to ensure that it’s not seeing any additional packages to update.

But if not, you should be in good shape!


mmh yes… but the application i run (ownCloud) is whining about this:

“cURL is using an outdated NSS version (NSS/3.19.1 Basic ECC). Please update your operating system or features such as installing and updating apps via the app store or Federated Cloud Sharing will not work reliably.”

So really I don’t feel like I am in good shape.

Would it be solved on installing a new version of cURL (as that is an old one too on CentOS; 7.19 while latest is 7.48 but not available on CentOS yet)?


Linux distros don’t typically change the versions of the software they ship with.

For example, CentOS 6 shipped with PHP 5.3.3 over 5 years ago, and that’s still the PHP version available for it today.

That doesn’t mean it’s full of bugs and security holes.

What they do is backport bug fixes and security fixes into the versions they ship. That keeps the way software works from changing over the lifetime of the distribution, making it more stable.

So what you’re seeing there is normal behavior.

Now, I can’t speak to ownCloud and the listed requirement of a newer NSS version… I’m not really familiar with all that.

Unfortunately, if that’s a requirement for what you’re trying to do, you may be stuck having to changing to a non-standard software version.

There appear to be some details on the issue you’re experiencing here:


According to that, RHEL/CentOS are working on that issue, but the bugfix is still pending.

So your options would be to update to a non-standard software version, wait until they fix the bug, or you could always switch to a different distro (assuming other distros have resolved that issue).


Thanks Eric,

I know that link, it was telling about the NSS version being too old… so I was happy there was an update today… now cURL is the one not really helping, having still 3.19 in its features…
So best bet is I have to wait for a cURL update, is that correct? Or could I even uninstall en reinstall cURL?

Me, being the noob here…