Update issue site down?

SYSTEM INFORMATION
Debian 12 REQUIRED
Webmin version REQUIRED
Virtualmin 7 REQUIRED
Related packages SUGGESTED

Hi to all,

Update don’t work:

Failed to fetch https://software.virtualmin.com/vm/7/gpl/apt/pool/main/v/virtualmin-config/virtualmin-config_7.0.20_all.deb Could not connect to software.virtualmin.com:443 (51.158.66.131). - connect (113: No route to host)

is the server down ?

Tks

No route to host is a network error.
It means that somewhere on the route between two devices there is a misconfigured network.
is this your network or virtualmin’s my guess is your network as I just connected fine. Have you changed anything in the webmin → network → network configuration ?

Check what the following command outputs:

ip route show

Later, you can add a route using Webmin / Networking ⇾ Network Configuration: Routing and Gateways page or by running the following command:

ip route add 1.2.3.0/24 via <gateway_ip>

Just as a point of reference, I just clicked on the provided links and they worked.

That’s not going to solve generally broken network. A static route just for Virtualmin repos won’t fix any other problems with networking they have (presumably something general is wrong, since we don’t require special routes to reach our servers).

The server is not down. Try a traceroute to see where it’s failing.

That’s right. However, I have never suggested adding a static route “just for Virtualmin repos.” This is a misunderstanding.

Then what was this about?

ip route add 1.2.3.0/24 via <gateway_ip>

That’s a static route to a specific destination.

You’re right! That’s wrong! I got distracted, as I initially implied the default route, i.e.:

ip route add default via 10.211.55.1 dev enp0s5

This is a common issue for the “(113: No route to host)” problem.

It could also be related to IP forwarding settings and is often fixed by:

sysctl -w net.ipv4.ip_forward=1

Although those are just wild guesses, we don’t know exactly what is going on with the OP’s system.

It should never be an out-of-the-box problem!

Only if this is a VM and IP forwarding is off on the host machine (not the guest where Virtualmin is being installed).

A system does not need to be a router to access the internet.

1 Like

Hi,
I think something is wrong in webmin network config

I have that :

root@srv-aan:~#

ping software.virtualmin.com

ping: connect: Network is unreachable
root@srv-aan:~# ping google.com             
PING google.com(par21s11-in-x0e.1e100.net (2a00:1450:4007:80c::200e)) 56 data bytes
64 bytes from par21s11-in-x0e.1e100.net (2a00:1450:4007:80c::200e): icmp_seq=1 ttl=113 time=6.96 ms

maybe dns reply with an ipv4 address and something is wrong with the gateway?
Yes it is under Debian 12 on a VM
Thks for your help
Benoit

maybe check ipv4 is working for you? ping -4 google.com

Yes, why ipV4 don’t working?

ping -4 google.com
ping: connect: Network is unreachable

Check the network configuration, is this at home or VPS at a datacenter? Static or DHCP setup?

Other than that I think it is a poor showing that in 2024 software.virtualmin.com is ipv4 only.

Check your configuration with ip addr show from commandline and you will see the current network configuration. And then you can decide what to do next.

That may be true, but that doesn’t mean ipv4 shouldn’t be configured on said system.

Ok it is a home installation, on a DSM Virtual Machine the OS is Debian 12.

My home router have a gateway : 192.168.1.1
The


root@srv-aan:~# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 02:11:32:21:5b:cc brd ff:ff:ff:ff:ff:ff
    altname enp0s3
    inet 192.168.1.18/24 brd 192.168.1.255 scope global ens3
       valid_lft forever preferred_lft forever
    inet6 2a01:XXX:XXX:b640::2001:5000/64 scope global 
       valid_lft forever preferred_lft forever

I think the ipv4 config is wrong somewhere
Tks for your help

Ok I have added the route via my gateway with
'ip route add default via 192.168.1.1 dev ens3`

Ipv4 is now ok and update is working.
but the gateway was already before in webmin/network/gateway/default but don’t working
Now I can update