Update crash

All was working well till i received update 4.16 yesterday and once installed Apache2 would not start. NGINX mySQL BIND9 SSH ProFTP all work with update. On Apache start

Failed to start apache :

  • Starting web server apache2
    [Wed Apr 01 11:13:01 2015] [warn] NameVirtualHost fe80::21b:24ff:fe51:2b93:80 has no VirtualHosts
    [Wed Apr 01 11:13:01 2015] [warn] NameVirtualHost 192.168.1.13:80 has no VirtualHosts
    (22)Invalid argument: make_sock: could not bind to address [fe80::21b:24ff:fe51:2b93]:80
    no listening sockets available, shutting down
    Unable to open logs
    …fail!

Deactivated all virtual websites and tried again, same story.

On validation i get;
Apache website : No Apache virtual host for wwwwww.net found on all three virtual sites.

I checked there are no running Apache instances to “kill” but there are 2 running processes that say they are not running (so cannot kill) but refresh themselves

18665 root 0.0 % sh -c ps --cols 2048 -eo user:80,ruser:80,group:80,rgroup:80,pid,ppid,pgid,pcpu, …
18666 root 0.0 % ps --cols 2048 -eo user:80,ruser:80,group:80,rgroup:80,pid,ppid,pgid,pcpu,vsz,ni …

I am assuming this is a SSL crt issue. I have tried unencypting and issuing a new encrypted cert still no luck.

Any advice or help would be much appreciated

Howdy,

Can you describe your setup there?

Are you running both Apache and Nginx?

It looks like there’s some sort of port conflict going on – Apache is trying to start, but is unable to bind to port 80.

If you’re running both Apache and Nginx, which ports are they each supposed to listen on?

-Eric

NGINX runs on port 8080. Varnish is on port 808 with pound backending between 443 to 80 on the Apache virtual sites. Apache2 runs on port 80. Even with all other systems deactivated Apache still will not start? All was good till upgrade? By the way virtualmin is a tool no netsysadmin can live without. Thanks

Howdy,

Okay, thanks, that helps.

What is the output of this command:

netstat -anlp | grep :80