Update Broke Server

Hi all,

I just ran an update to my Virtualmin server and it got through one update and hung and now when I try to update I just get errors and now I cant add any more domains either. The domains that are already on the server seem to still be working.
Here is the errors I get now when I try to update:
Now updating webmin-security-updates …

  Installing package(s) with command apt-get -y --force-yes -f install webmin-security-updates ..

  .. install failed!

Now updating webmin-virtualmin-awstats …

  Installing package(s) with command apt-get -y --force-yes -f install webmin-virtualmin-awstats ..

  .. install failed!

No packages were installed. Check the messages above for the cause of the error.

I have just noticed that the messages log is showing this:
Mar 31 18:00:03 hosting1 syslogd 1.4.1#18: restart.
Mar 31 18:20:04 hosting1 – MARK –
Mar 31 18:40:04 hosting1 – MARK –
Mar 31 19:00:02 hosting1 exiting on signal 15
Mar 31 19:00:03 hosting1 syslogd 1.4.1#18: restart.
Mar 31 19:20:03 hosting1 – MARK –

over and over again.

Any ideas?<br><br>Post edited by: brett.huth@globalspan.com, at: 2008/03/30 17:23

I have no idea what those log entries are. I don’t think they’re related to package management. And, I’d suspect a bug in whatever is generating them, since chatter like that is pointless and makes it harder to find real problems.

As for the package updates thing, try updating from the command line:

apt-get update
apt-get upgrade

See if you get any more useful errors out of it. I’ve noticed that apt-get gets into a stupid state that requires manually running dpkg with options under some circumstances. I have yet to figure out what triggers it.

Cheers Joe looks like dpkg --configure -a fixed it. Must have been the hung package install previously.

It looks like syslog is restarting after the hourly cron jobs. Ive never noticed this before is it normal?