Uninstalling webmin need answer asap

So ever since the last webmin update it hasn’t worked correctly.

Is it safe to uninstall without it affecting virtualmin and then reinstall.

Howdy,

Reinstalling Webmin isn’t likely to fix any problems, and does come with the risk of causing some problems.

What problems are you having specifically?

-Eric

This is what I get. Whenever I try to do almost anything in webmin that requires installing. or running a package like spamassassin.

Failed to install standard module : The specified module does not exist

Call Stack Trace

File Line Function
/usr/libexec/webmin/webmin/install_mod.cgi 65 WebminCore::error
(eval 47) 6 (eval)
/usr/libexec/webmin/miniserv.pl 2333 (eval)
/usr/libexec/webmin/miniserv.pl 917 miniserv::handle_request

This all happened when I did the last webmin update.

Howdy,

Hmm, I’m a little confused as to what specifically you’re trying to install… are you saying that you’re attempting to install SpamAssassin?

To do that, you’d want to go into System -> Software Package Updates, and in there, you can perform the SpamAssassin installation. From the error you’re getting, it sounds like you’re in the Webmin module screen.

If that’s not what you’re trying to do – let us know which screen you’re in, and an example of something you’re trying to install that generates that error.

-Eric

doesn’t matter what screen,

this happens for almost anything I attempt.

Howdy,

Well, that particular error is specific to one particular screen.

We’ll need to know exactly what screen you’re on, what action you’re attempting to perform, and the exact error you receive when attempting that.

Also, do any additional errors show up in /var/webmin/miniserv.error?

-Eric

Interesting enouugh that error came up while in I tried to start Wsftpd from the system information page and spanassassin as well.

It also happens sometimes when trying to start almost anything through webmin. as I said the last update did something. I am assuming that it must be something on my system since I don’t see anyone else hollering.
But I could use some direction and help with this.

Yeah, unfortunately, you’re the only one who’s mentioned seeing that particular issue. It’s not likely to be something that a simple reinstall would fix, though we’ve occasionally seen things fixed by restarting the Webmin service, if it didn’t restart properly during the installation process.

If that doesn’t help, can you paste in the exact error you receive when trying to start SpamAssassin from the System Information screen?

That would be different from the error you shared above.

Also, do any additional errors show up in /var/webmin/miniserv.error?

Lastly – what kind of server do you have… is it a dedicated server, or a VPS? If it’s a VPS, what kind of VPS? Xen, KVM, OpenVZ?

-Eric

that is the error. That is why I posted it,
But as of today the mail log files are showing spamd as working ,
what does the posted error mean and point to?

Thanks