Unable to upload files (images) with PHP

Hi there.

I have been using a PHP script that made it possible for me to fast and easily upload images when I needed to.

I recently bought myself a VPS and set-up Virtualmin with the install script.

Everything went without any errors and I created my first virtual host and got the domain up.

However, I copied my files from my former server, but the PHP script does not work?

I made sure the directory where the files should get uploaded to got the proper rights.
I also thought it might have been the upload size, but I tried with a picture that’s about 40kb. Still didn’t work.

The php script will even give specific errors if something is wrong, but when I hit the upload button, the page just turns blank and only shows the background.

Is there something Virtualmin turns off by default? The PHP script worked perfectly on my other server.

I even tried with a whole other PHP script, but the same thing happen.

Any help is appreciated.

If you wanna see the code, just let me know.

Howdy,

Are you seeing any errors in the error log? That’s located in $HOME/logs/error_log. That may assist in troubleshooting the problem.

-Eric

There’s also PHP options to render error messages (also warning, info etc.) into the output. By default those are turned off for security reasons, but for debugging you might want to switch them on, to detect errors in your PHP code.