Unable to Update Usermin

I am running the latest VM Pro on a CentOS 5.3 server and cant seem to update usermin. I have even tried removing all other repos so there is only the virtualmin repo, and I still get the following.

Resolving Dependencies
–> Running transaction check
—> Package usermin.noarch 0:1.410-1 set to be updated
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtualmin-nuvola
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtualmin-nuvola
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtual-server-mobile
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtual-server-mobile
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtual-server-theme
–> Processing Dependency: /usr/libexec/usermin for package: ust-virtual-server-theme
–> Finished Dependency Resolution
2:ust-virtual-server-mobile-2.1-1.noarch from installed has depsolving problems
–> Missing Dependency: /usr/libexec/usermin is needed by package 2:ust-virtual-server-mobile-2.1-1.noarch (installed)
2:ust-virtual-server-theme-6.9-1.noarch from installed has depsolving problems
–> Missing Dependency: /usr/libexec/usermin is needed by package 2:ust-virtual-server-theme-6.9-1.noarch (installed)
ust-virtualmin-nuvola-1.155-1.noarch from installed has depsolving problems
–> Missing Dependency: /usr/libexec/usermin is needed by package ust-virtualmin-nuvola-1.155-1.noarch (installed)
Error: Missing Dependency: /usr/libexec/usermin is needed by package ust-virtualmin-nuvola-1.155-1.noarch (installed)
Error: Missing Dependency: /usr/libexec/usermin is needed by package 2:ust-virtual-server-mobile-2.1-1.noarch (installed)
Error: Missing Dependency: /usr/libexec/usermin is needed by package 2:ust-virtual-server-theme-6.9-1.noarch (installed)

I know this is an old post but I just ran into this issue today. Same error. It seems to be caused by yum. I was able to run the update after going to the command line and running ‘yum clean headers’, then ‘yum clean packages’, and then ‘yum clean metadata’. After that then try the update again. Should work.

I also had this problem, and running the YUM CLEAN … commands solved it.

Thanks aewilliams

You could simplify your command by using ‘yum clean all’.