Unable to set disk quota

I am unable to set disk quota through Virtualmin module in Webmin. Virtualmin shows The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled. . I am on Ubuntu 9.04 . Ref: https://www.virtualmin.com/system/files/ScreenShot006_1.jpg Please help.

afaik, you can not set quota on a vps.

Then can you recommend me how I can restrict the size of an FTP account and fix the bandwidth that a subdomain will comsume ?

Your screenshot isn’t working for me. Per haps if the directory wasn’t /home you would be able to use quota’s

look in webmin - system - Disk and Network Filesystems for clues on your filesystem.

(btw i see you’re running jaunty, that isn’t exactly a server OS.)

I use Jaunty server edition not the desktop edition. Screenshot repost : http://img198.imageshack.us/img198/8692/screenshot006ihg.jpg

can you try to set the location of Home to /home instead of /var/www ? This may do the trick.
Else you may want to try to set the module to / (The Reiser filesystem)

Do you have two files in the root of your system named: .aquota.user and aquota.group ?

(I meant that Jaunty has a short lifecycle as opposed to Hardy Heron, 8.04 LTS, which would be better for a server)

I have the files .aquota.user and aquota.group in the root. I have used the instructions as given in http://mr-euro.com/virtualmin-suexec/ ro mount my /var/www directory to /home . It is not accepting The Reiser filesystem . Showing error “mount: unknown filesystem type ‘reiserfs’” . I think Ubuntu can be seamlessly upgraded from one version to another without any hitch. Please help .

You CAN set quota on OpenVPS and on Xen VPS. (i.e. I DO)

Please post the full contents of your /etc/mtab and /etc/fstab files

Paste of /etc/mtab and /etc/fstab files ---- > http://pastebin.ca/1505755

suExec is an execution mode for apache available by default in virtualmin pro. You are running GPL which is mod_php (though you can manually make the GPL version with suExec and execute Apache with mod_fcgid).

Try to comment out or delete the entry (after you have made a backup of the file) “/var/www /home none rw,bind 0 0” in mtab
You probably need to restart after that.

I think you also want to read this thread:
http://www.virtualmin.com/node/10684

If I comment out “/var/www /home none rw,bind 0 0” in mtab , I think it will unmount /home from the /var/www directory . And it is certainly not working , because it seems that Webmin treats /home as the Virtual server home directory , where as Ubuntu considers it as /var/www . So I was forced to mount it that way. And so far I have not faced any system error particularly related to Ubuntu newer version . Webmin installs most of the dependencies through apt-get which are configured to deliver the latest Jaunty and the modules seems to be interfacing with them quite fine … till now.

Did you try to reboot the vps? then repost the full contents of your /etc/mtab and /etc/fstab files

When exactly are you getting this mount error? It looks like your kernel or mount command doesn’t know about reiserfs…

After restarting after commenting out the /etc/mtab as per your instructions http://web2dziner.com lands up to default Apache “It works!” page . www.web2dziner.com and other subdomains are refusing to open HTTP 404 error. Reverting back to old settings.

root@ns1:/# cat /etc/mtab

/dev/simfs / reiserfs rw,usrquota,grpquota 0 0

root@ns1:/# cat /etc/fstab

proc /proc proc defaults 0 0

none /dev/pts devpts rw 0 0

what did the quotas tell you (logs) when you had rebooted the vps and before you reverted to the old settings?

The link you made (/home - /var/www) disappeared from mtab after rebooting the vps, it will need to be in fstab as well to make it permanent.

Just some friendly advice: What I would do at this point is to reinstall the vps with a supported Ubuntu LTS 8.04 or even better Centos 5.3 and use the install.sh to install virtualmin properly. You should have a working box in an hour, provided you have enough ram (256mb I would say) and start with your current FQDN - ns1.web2dziner.com. http://software.virtualmin.com/gpl/scripts/install.sh

since virtualmin has no packages in its repository for 9.04, it 's just a matter of time before something (else) may or may not break (but why take the risk?).

Or have Eric (if he wants to) log in to your box, per haps he can find the errors. Sorry to say, my knowledge of Ubuntu is not enough to efficiently fix this issue.

The Virtualmin says
“The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed.” before I apply the command " mount --bind /var/www /home " . Do you think those problems are arising because I am using Ubuntu 9.04 and would not happen if I use Ubuntu 8.04 LTS . Seems not to be so. The problem looks very generic in nature . But if it seems so , I will certainly think about reformatting , I have put a lot of labour to set up this box and would not like to lose it and start from scratch.

The problem looks very generic in nature
Not really.

You should not have any warnings about suexec and docroot. This is due to having Apache not from the Virtualmin repositories but from Ubuntu (or other) repositories. (there are no 9.04 packages at virtualmin)

You can recompile, but when updates come, they won’t come from virtualmin, hence no saying what trouble you will run into.

When you use a supported (minimal installation) grade A OS, the install script will add the virtualmin repositories to your system and will install Apache and all other needed services and configure them correctly.

There may still arise small issues, but knowing you get your stuff from the place where it should come from, makes troubleshooting a lot easier and less guessing.

I have put a lot of labour to set up this box
In my experience, Virtualmin will do the hard labour for you when using the install.sh. I also have a vps somewhere with 256mb ram, running centos 5.3. That GPL install went flawless.

I can not make the decision for you, that’s up to you. I can only give you advice as is and share my experience with you. Per haps others can chip in their opinion too.

Hi Anirban1987

I think you’ve gone astray with the idea of mounting /var/www/ on top of /home; but if you’re going to persist with that, you’ll have to make appropriate entries into /etc/fstab to create the mount and the quotas. The mtab file is not for you to edit.

The virtualmin install script results in this for suexec:
cat /etc/apache2/suexec/www-data
/home
public_html/cgi-bin

The first two lines contain the suexec document root and the suexec userdir

suffix. Both features can be disabled separately by prepending a # character.

This config file is only used by the apache2-suexec-custom package.