Unable to login to Webmin

I’ve been mucking about with changing my hostname, and now I’ve run into an issue.

When attempting to login to Webmin via HTTPS (which has worked fine prior to my recent reboot), at https://server.mydomain.com:10000, my browser gives me an SSL protocol error. When trying http://, I can get the Webmin login dialog, but entering my username and password just causes a refresh of the screen (i.e., not a login error, but a loop back to the login dialog). I seem to remember a setting somewhere that only allows HTTPS logins, which might be causing this? If so, can I disable it via command line?

The SSL certificate is all valid and fine. Does there need to be a valid Apache entry in httpd.conf for server.mydomain.com:443? (There is, but changes to it don’t seem to have any effect).

Any light on this appreciated.

Foul

No. Webmin does not run under Apache.

In addition to the hostname, you can access Webmin and Virtualmin via the domain name of any of the virtual servers hosted on the Virtualmin system.

For example:

https://hosteddomain.tld:10000
Or
https://admin.hosteddomain.tld

Using a hosted domain to access Webmin / Virtualmin will likely circumvent the issue that you are experiencing after you submit your credentials.

If all fails, use port 10000 on the IP address of your server.

Thanks for the assistance! I was able to get it working again.

Going to mydomain.tld:10000 didn’t work; it just timed out. Going to myipaddress:10000 did bring up the dialog, and this time it accepted my username/password. The problem seems to be in the most recent Webmin update of a few days ago, it reset my Webmin SSL cert locations, which are in the default LetsEncrypt/live folder, not in the /home folder where Webmin wants to put them.

Foul

Sounds like a dns issue if timed out. Do some testing at https://mxtoolbox.com/
Steve

I use Cloudflare DNS. The domain itself is fine; just won’t go through port 10000 to Webmin.

Foul

you used a ip on port 10000 and it works, therefore its a dns issue.

DNS has nothing to do with ports. The DNS to the domain itself resolves fine.

Regardless, it’s all working fine now, so this topic can be closed.

Foul

CloudFlare doesn’t proxy port 10000, so this is the reason.
If you disable the proxying, it will also work using the domain.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.