unable to install virtualmin in amazon linux

Team,

unable to install virtualmin in amazon linux

get error message:

Failed to detect operating system

Pls help.
thanks and regards

Maheswaran S

Amazon Linux is not among the Grade-A supported distributions and not recommended for Virtualmin. It is a Grade-B supported system, but the installer script probably does not know the latest version yet.

See here for recommended distros (to avoid problems, use only Grade-A) and problems with Grade-B distros: https://www.virtualmin.com/os-support