Unable to FTP - No Matter what I have tried.

Installed a couple months ago, could not ftp in, and just getting around to this again…and need to post as I need to get some sleep :slight_smile:

First up there was a sh**load of updates.,…lol and all are done as well.

ProFTP running, etc…

Sorry for the post, been at that for hours on and off…and tons of reading but no luck.

Everything looks proper, using IP for access, nameservers

Still frigging getting 530 error

Decided to try to make an FTP user, other than the domain name one =

Failed to save mailbox : Failed to open /home/XXXXXX/etc/dav.digest.passwd for writing : Permission denied at …/web-lib-funcs.pl line 1397.

At wits end,
Please help.

Are you trying to use WebDav or FTP?
Do you allow all extra non-admin accounts to access FTP?


Well, this may be due to the lack of sleep that you described, but I’m having a bit of trouble following what problem you’re having there :slight_smile:

It sounds like you mentioned that you’re having a problem FTP’ing? If so, what are the errors that you’re seeing? Can you paste in the full error messages?

You pasted in an error at the end there that appears to be a Virtualmin error – when does that occur exactly? Does that occur when trying to create a user?

Also, what is the output of this command:

ls -la /home/XXXXXX/etc/

Please note, bottom line ?

Checking Configuration

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

Your system has 2 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Your Postfix version does not support per-domain outgoing IP addresses.

Apache is installed.

The following PHP versions are available : 5.3.3 (/usr/bin/php-cgi)

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and running.

Plugin DAV Login is installed OK.

The AWstats command /usr/share/awstats/wwwroot/cgi-bin/awstats.pl was not found on your system.

… your system is not ready for use by Virtualmin.


Well, it’s unusual that the awstats command isn’t installed on your system, though that wouldn’t affect FTP usage.

And the info there also mentions that ProFTPd is installed.

Do you have any thoughts on the questions that I asked above?



[root@lassd ~]# ls -la /home/bestseodeal/etc/
total 16
drwxr-xr-x 3 bestseodeal bestseodeal 4096 Oct 6 07:29 .
drwxr-x— 12 iamjim iamjim 4096 Dec 14 20:09 …
-rw-rw-r-x 1 bestseodeal bestseodeal 111 Oct 6 07:29 dav.digest.passwd
lrwxrwxrwx 1 bestseodeal bestseodeal 12 Oct 6 07:29 php.ini -> php5/php.ini
drwxr-xr-x 2 bestseodeal bestseodeal 4096 Oct 6 07:29 php5
[root@lassd ~]#

Hmm, well, you didn’t mention what errors you were seeing when trying to FTP, but I have a suspicion what they might be based on your “ls” output.

It looks like the “/home/bestseodeal/etc/” directory is owned by the user/group “bestseodeal”.

However, the /home/bestseodeal directory is owned by “iamjim”.

Those dirs are typically all owned by the same user though.

Knowing that, I suspect that some permissions got changed somewhere along the way that are causing some problems.

What you may want to do is go into Limits and Validation -> Validate Virtual Servers -> Fix Permissions, and you may want to have it fix the permissions on that particular domain.

After doing that, does FTP begin working properly for you?


Howdy Eric, and of course (haven’t said it yet) but thanks for trying to help. :wink: And yes, after the first output and before I replied (or opened my mouth) I had tried it as user > iamjim < yesterday

1) For simpletons sake, to verify (I hope) that nothing I did a) create new and "simply" try again [root@lassd virtualmin]# pico businessdatabaselist.com_error_log [Wed Dec 17 05:57:47 2014] [error] [client 66.153.xxx.xx] Directory index forbidden by Options directive: /home/bizdata/public_html/ [Wed Dec 17 05:57:49 2014] [error] [client 66.153.xxx.xx] File does not exist: /home/bizdata/public_html/favicon.ico [Wed Dec 17 05:57:49 2014] [error] [client 66.153.xxx.xx] File does not exist: /home/bizdata/public_html/favicon.ico

Above, was trying to FTP in, to a newly created account
Tried domain based first, then IP based

[root@lassd virtualmin]# htop

Did your Permissions trick fix, on the one domain = output

[root@lassd virtualmin]# ls -la /home/bestseodeal/etc/ total 16 drwxr-xr-x 3 bestseodeal bestseodeal 4096 Oct 6 07:29 . drwxr-x--- 12 bestseodeal bestseodeal 4096 Dec 17 05:51 .. -rw-rw-r-x 1 bestseodeal bestseodeal 111 Oct 6 07:29 dav.digest.passwd lrwxrwxrwx 1 bestseodeal bestseodeal 12 Oct 6 07:29 php.ini -> php5/php.ini drwxr-xr-x 2 bestseodeal bestseodeal 4096 Oct 6 07:29 php5 [root@lassd virtualmin]# ls -la /home/bizdata/etc/ total 16 drwxr-xr-x 3 bizdata bizdata 4096 Dec 17 05:56 . drwxr-x--- 11 bizdata bizdata 4096 Dec 17 05:56 .. -rw-rw-r-x 1 bizdata bizdata 107 Dec 17 05:56 dav.digest.passwd lrwxrwxrwx 1 bizdata bizdata 12 Dec 17 05:56 php.ini -> php5/php.ini drwxr-xr-x 2 bizdata bizdata 4096 Dec 17 05:56 php5 [root@lassd virtualmin]#

OK, tried the bestseodeal FTP in again. 530 password error.

Now, day 3 of 10% of my days on this, [and armpits working up a small sweat as well] and this was after as i mentioned 2 months ago install…and tossing this aside for the same reasons after doing the install

[just venting], and kicking myself in the butt for not taking Nick’s cpanel job offer up back in 2004 after they outsourced at Microsoft.

Over a year ago, I tossed this up and had no problems at all brother?

Thanks again for the help, BUT?

Today should be a less hectic day, so I’ll be able to respond faster also sir.




The errors you’re seeing in “businessdatabaselist.com_error_log” are normal website related errors, those aren’t FTP errors. You’d get those errors if you were trying to access a website that didn’t have a website uploaded yet.

Your permissions appear to be correct now.

Now, regarding logging in – what distro/version is it that you’re using there? If you’re using CentOS, what is the output of this command:

rpm -qa | grep proftp

Also, I’m curious if you’re able to access your accounts using SSH or SCP, rather than FTP (at least as a test, though note that if possible, SSH/SFTP is a much more secure protocol anyhow, you can use a tool such as WinSCP to access that).

And I know you’re just venting, but we normally don’t see these sorts of issues… I don’t think you’re running into a Virtualmin vs cPanel sort of problem here :slight_smile:


No, the cPAnel mention was that I could have went to work them :wink:

This has come a long way

After above post and another domain? Tried WinSCP…no go also. Password issue it said

SSH into account name = OK

[root@lassd virtualmin]# rpm -qa | grep proftp
[root@lassd virtualmin]#

Ah, it looks like your FTP package came from a third party, which can cause the problem you’re experiencing.

Take a peek at the article titled “Why does PHP / ProFTPd no longer work after performing updates? (I’m using CentOS, and enabled third party repositories)” here:


Hey “Batman” -smile-, You know I mean Eric.

  1. Of course thanks for your help in this issue - Still not sending mail & getting the AWSTATS message

  2. Spent way too long reading/googling etc yesterday again…

  3. Riddle me this Batman?

Why didn’t the “Other Eric” say this: https://www.virtualmin.com/node/28546 that I just found this morning…

Haha - All in jest brother, uploading now finally (2 months later back at the ranch) and for sure know how one forgets things… I’ve forgotten all the eprom programming I’ve done in the late 80’s