Unable to delete / rename Sub-Server

I have 2 domains, say:


I’m trying to delete test.domain.com, and I get this error:
Virtual server test.domain.com cannot be deleted, as it contains DNS records for server domain.com

I get a similar error for a rename.

I’ve tried removing the dns records for both, but I’m still presented with the same error.

Hello volupheles,

Have to try to disable DNS feature on edit Feature Manager for test.domain.com only and then remove / disable the virtual server ?

Yes, I tried removing DNS as a feature. I even tried on both domains to be certain. It still doesn’t allow deletion / rename.

Hello volupheles
on bind name server in webmin try and remove the domain.com entries.
I.e make sure only to remove from test.domain.com records not the direct entries done
also not the virtualmin created entries

I still haven’t fixed this issue. I can confirm all DNS records for the domain I wish to delete are gone.

If possible, temporarily disable dns for all of your servers/sub servers. Then turn bind off (webmin). Try to delete. See if that clears the problem. Once that’s done, you can enable bind and enable dns for the servers.