Unable to create a VM with > 4GB RAM

Perhaps I am missing a setting somewhere. Whenever I try to create a VM with > 4GB RAM, it just fails. If I create the VM with 4GB then go back and try to upsize it, I get the error about memory greater than max memory. I was able to manually edit the config file, xm delete and xm create but that defeats the point of cloudmin.

Has anyone seen this before or know where to change the max memory allowed when creating VMs?

Check what you have “Maximum memory for Xen instances” set to in Cloudmin Settings -> Cloudmin Configuration -> Open Source Xen

That worked… Funny it never gave an error. It just stalled. I swear I checked that before! Thanks!!

If it doesn’t provide an error, that’s probably a bug. Might want to file a ticket, if it’s reproduce-able, so Jamie can fix it.