Unable to connect software.virtualmin.com, thus not able to install virtualmin

From last 48 hours we are unable to connect to software.virtualmin.com. we found this issue while we are trying to install virtualmin gpl to on of our server which is on our network 45.195.75.X .

Our network & server team has been tried everything from our side. There is no outbound or inbound blocking in our network.

Our network team suggest that possibly our network pool is blocked in virtualmin side.

Question is that how to contact team virtualmin to remove this blocking if any?

Team Cheree Infomedia.

I have earlier (~4 hrs ago just installed ok on a new VS (as recommended) - I admit it was a LEMP install but that shouldn’t be any different.
It went smoothly without any errors (as it always does)

$ /usr/bin/wget https://software.virtualmin.com/gpl/scripts/install.sh

$ sudo /bin/sh install.sh --bundle LEMP

As for contacting the"team" they are watching every post but do like the occasional shut eye. Plenty of other folk are on here regularly.

PS. We really do need to have some idea of OS etc just in case you are trying to install on something weird and unsupported.

It is working on our other network servers fine but issue with this network only.

We are using CentOS 7.x

Thanks for the extra info.
Sounds to me as if you box is not connected to the internet!

I assume that some basic checks have been done. When you say it works on other network it seems to be a network connectivity issue rather than Virtualmin. Can the box even do a simple apt install? (I’m not a CentOS user)

yeah. system is connected to pubic network & working fine for other software installation using yum. other than accessing virtualmin system, everything is working.

This is happening to every system sharing same IP pool. I feel that our pool is blocked in virtualmin server side. I don’t know the reason but it is one the possibility.

I assume the IP pool is not blacklisted. (I am pretty sure that Virtualmin would not blacklist any IP - I cannot see any reason to do that)

I have only had experience of installing on virgin clean boxes not on using any IP pooling. Though I can vaguely understand why that might interfere with Virtualmin handling of IP once it has loaded - I cannot understand why you cannot even load it. I assume that there are no errors with the above commands - as the script is pretty good at throwing messages about problems during install.

I am also a little confused as you implied that Virtualmin has loaded ok on other boxes (presumably in the same IP pool) Is it something about the management of the pool?

Are you using a firewall within your network? I ask because firewalls such as pfsense/snort will block traffic depending on their default rules.

We run fail2ban or sshguard on all of our servers. So, it’s possible attacks (i.e. attempts to login via ssh) coming from an IP would lead to it being blocked, but we wouldn’t have blocked a whole network block, AFAIK (I mean, I don’t know how that’d happen unless our provider did it).

That IP doesn’t show up in our fail2ban log for the repo server, nor in the firewall rules, so that’s not the case here.

Without the actual IP, I can’t really do much network testing to see where the disconnect is happening.

we have a firewall but we have checked the whole network & nothing is getting blocking here. We also talk to our uplink provider and they said it is not the issue from there side as well.

here are the traceroute output from our server -

[root@host1 ~]# traceroute software.virtualmin.com
traceroute to software.virtualmin.com (, 30 hops max, 60 byte packets
1 ( 0.324 ms 0.335 ms 0.350 ms
2 ( 1.255 ms 1.452 ms 1.984 ms
3 ( 13.709 ms 15.367 ms 15.721 ms
4 ( 11.034 ms 11.000 ms 11.122 ms
5 ( 132.042 ms ( 110.072 ms ( 106.310 ms
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

Hope this would help .

here is the IP of one the server But I strongly believe that pool is blocked somewhere.

Could this be why?

from dnsbl.spfbl.net blacklist

No. Reverse DNS doesn’t matter.


It has been resolved now. This was blocked by uplink provider. However, when we are going to start install it again. it is showing following SSL error -

OpenSSL: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
Unable to establish SSL connection.

Hello there, I can confirm this.
We cannot connect to https://software.virtualmin.com from any of our systems, either. The error message shown in the browser is ERR_SSL_PROTOCOL_ERROR (in latest Chrome), also apt can’t connect.

Looks like an SSL misconfiguration on software.virtualmin.com?


Can confirm also seeing SSL errors via updating yum cache, or trying to download the script again:

[root@host1 ~]# wget https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh
--2023-08-03 10:28:43--  https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh
Resolving software.virtualmin.com (software.virtualmin.com)...
Connecting to software.virtualmin.com (software.virtualmin.com)||:443... connected.
GnuTLS: An unexpected TLS packet was received.
Unable to establish SSL connection.

Thanks for your heads up! @Joe is aware and will fix that as soon as possible.

Sorry about that!


Hi there, I got the same error:


Hi, Today i plan to install Virtualmin on my server but
the url
https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh is unavailable


Using wget intead:
Resolving software . virtualmin . com (software . virtualmin . com)…
Connecting to software . virtualmin . com (software . virtualmin . com)||:443… connected.
OpenSSL: error:0A00010B:SSL routines::wrong version number
Unable to establish SSL connection.

There is a workaround?

1 Like

That’s a new and unrelated issue.

For the new issue: Our hosting provided moved our instance to a new physical server, and things went weird. Fixed now.

1 Like