Unable to add another interface to Virtual Machine in KVM

Hi all,

I have my bridging/networking in place via a guide from my host: http://wiki.hetzner.de/index.php/KVM_mit_Nutzung_aller_IPs_aus_Subnetz

I can’t seem to add a second IP address to a machine, which I’ll need to host SSL protected websites, as well as host my own DNS server.

Steps I’m taking:

  1. Create the new VM with New System -> Create KVM Instance -> Create empty System
  2. Once the system is created, go into System Configuration -> Network Interfaces and set eth0 to the proper bridge on the host. Add eth1 via ‘Add a real interface’ (it’s the only option I have on that page).
  3. Install the OS. During installation, the OS detects that it has two eth devices, and can use either one.
  4. Once the OS is finished installing, the machine shows eth0 offline and eth1 as ‘No such device’ when I try to $ sudo ifconfig eth1 up from a Ubuntu 12.04 guest. (therefore killing all internet connectivity to the guest. Attempts to try to get it to reconnect are unsuccessful and I must delete and recreate the machine to get eth0 to reconnect

I read somewhere that a new IP has to be added as a ‘virtual interface’ in System Configuration -> Network Interfaces but I don’t have that option, I can only add ethN devices.

Any ideas?

So after fiddling with it for a while, I’m able to get eth1 to communicate with the outside world and ping back. eth0 shows ‘Active Now? -> No’ in Network Configuration of Cloudmin, but I’m able to configure it in the guest (give it the IP and ‘ifconfig eth0 up’. Adding an eth2 to the guest causes it to lose all connectivity to and from the outside world and the host.

Blah >.<

After changing some stuff around yet again, I have eth0, eth1 and eth2 all showing active, with their own bridges to the host, but only eth0 now returns any ping. eth1 and eth2 are detected by the guest as active devices, I can assign them IP addresses, but they don’t return ping from the outside.

And now I’m really puzzled. I rebooted the machine and now eth2 IP returns ping, eth0 and eth1 are both detected by the guest and active but they don’t return ping. >.<

Hi, just to support your request for support, as you are not the only one with NIC issues http://www.virtualmin.com/node/23111