Unable to access virtualmin on a fresh install

I am on a linux debian 9.
The debian 9 was without any prior installation. Just the updates.

I tried to follow the guide here:

It would be nice if that guide mentioned where to get the virtualmin sources:
deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-stretch main
deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main

I used the minimum install since the server has limited resources 1GB RAM.

I could not access virtualmin remotely (firefox complains about security and ie won’t show anything) so I tried to access the virtualmin page from the console this is what I get:

localhost:~# wget https://:10000 --no-check-certificate
–2020-01-10 15:35:09-- https://:10000/
Connecting to :10000… connected.
WARNING: The certificate of ‘’ is not trusted.
WARNING: The certificate of ‘’ hasn’t got a known issuer.
The certificate’s owner does not match hostname ‘’
HTTP request sent, awaiting response… 200 Document follows
Length: unspecified [text/html]
Saving to: ‘index.html.1’

index.html.1 [ <=> ] 4.67K --.-KB/s in 0.09s

2020-01-10 15:35:09 (49.7 KB/s) - Read error at byte 4786 (The TLS connection was non-properly terminated.).Retrying.

If you’re getting certificate error then you have access to the server. But if you’re starting with http and virutalmin is forwarding to https, sometimes it wont work if the local IP is wrong. Have you tried manually going to https://ip:10000 in the browser and have you tried the same in the browser but in private mode.


It’s recommended to use install.sh script on clean installs (“The Debian 9 was without any prior installation. Just the updates.”)

WARNING: The certificate of ‘’ is not trusted.

It’s not a problem, just hit Advanced (may vary from browser to browser)

…and later proceed:

Later, you can request valid, free SSL certificate using Webmin Configuration/SSL encryption/Let’s Encrypt page.

Yes I tried both https://[ip address]:10000 in the browser and in private mode and I get this on firefox:

Secure Connection Failed
An error occurred during a connection to [ip address]:10000. PR_END_OF_FILE_ERROR

Using IE, I get:

This page can’t be displayed

  • Make sure the web address https://[ip address]:10000 is correct.

Using Chrome, I get:

This site can’t be reached

[ip address] took too long to respond.


There are no option to continue or add an exception. Just a ‘Try again’ button.

I did use the install.sh script with the minimal option to install it. It did not give any warning or error during the installation.

It means there is no response from the server. Check your Firewall and add default port 10000 and 20000 to Firewall accept.


apt install ufw
ufw allow 10000/tcp
ufw allow 20000/tcp
ufw reload

Thanks to everyone for their help.

I finally figured what was the problem.

It was an external firewall that I had to set using a web control panel.
By adding the virtualmin port 10000, I was able to access virtualmin.

1 Like