Ubuntu - Quota stopped working


I’m running a Xen VPS with Ubuntu 12.04 & Virtualmin.

Maybe I did something wrong few weeks ago then I realized that quota has stopped working


/dev/xvda1 on / type ext3 (rw,noatime,nodiratime,grpquota,errors=remount-ro,usrquota)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)


/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/xvda1 / ext3 grpquota,errors=remount-ro,usrquota,noatime,nodiratime 0 1
#dev /dev tmpfs rw 0 0

and /dev/root is currently:
lrwxrwxrwx 1 root root 3 May 5 11:36 /dev/root -> md0

have no idea why, did try to enable quota from virtualmin and its just refreshing.

appreciate all the help :slight_smile:

thank you


Well, it looks like your root device is /dev/xvda, rather than /dev/md0, that may be the cause of the problem you’re seeing.

What happens if you try to manually restart the quotas on the command line though? Do you receive an error message of some sort?

You can restart the quotas using this command:

/etc/init.d/quota restart

Hi @andreychek
thx for the reply…

I did tried manually restart and got:

* Turning off quotas... quotaoff: quotactl on /dev/root [/]: No such device quotaoff: quotactl on /dev/root [/]: No such device ...done. * Checking quotas... quotacheck: Mountpoint (or device) / not found or has no quota enabled. quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

any chance that the symlink might be the cause? what should I do

last time I remember, I made patches for heartbleed and some updates… either this cause the quota to stop or the provider made changes.

thank you

Hi @andreychek

here are some updates…
I changed the current symlink with this command

ln -sf /dev/xvda1 /dev/root

now the quota is running again :slight_smile: thank you

all left with a minor question…would it be possible that the updates from Ubuntu be the cause to overide /dev/root symlink ?

anyway, thanks again for the help…



Hmm, I’m not entirely sure what caused the problem you’re seeing. Is it perhaps related to rebooting? I’d be curious if that symlink is correct after a reboot.


Hi Eric,

Did a reboot and quota seems to be ok, no changes for the symlink.

I’ll do a search again later, at least the quota is back to normal again

thank you Eric :slight_smile: