ubuntu 8.04 virtualmin 403 forbidden

I’ve spent numerous hours trying to figure this but coming up blank. Fresh install(have done it twice now same results) of Ubuntu 8.04 server only choosing openssh during install, then use the install.sh script and all goes well. Everything seems to be fine except whichever domain I try and view website I get the following: You don’t have permission to access / on this server.
I’m natting, IP of server 192.168.8.100 external 72.10.144.186. I even get the “You don’t have permission to access / on this server” if I just type in the browser http://192.168.8.100. I’ve checked group permissions and each virtual does have www-data as a member (apache). Any ideas??

thanks

DF

Do you have an index page in the public_html? The default configuration of Apache on some operating systems won’t offer indexes, and so if there is no index page, it will display this error–and it is behaving exactly correctly in doing so.

yes it has a index.html file, I even chmod 755 to see, same results.

reaching your server like http://72.10.144.186/ shows not the default website.

see attm

attm now then?

that’s because I had to switch over to a temp server I put online until I can solve this problem (I have production websites on it), I can quickly switch it back if you’d like to take a quick look (but need to keep the other online mainly during the day until I can fix this problem). (temp server is just ubuntu running postfix/webmin etc… no virtualmin, this is the reason I want to get virtualmin running on my new box so I can move these sites over too it and retire that server)

Here it is in a nutshell, I’m switching my server over too a poweredge 6400 and wanted to start using virtualmin instead of current webmin solution I’m using,I started completely fresh twice install went well no errors,except websites displaying:You don’t have permission to access / on this server. I even get this if I just try and browse to http://72.10.144.186. so in the meantime I had to switch back to the production server(just changed ip’s in my firewall port forwarding). I will be home aprox 5:30est and will switch port-forwarding back to the virtualmin machine for continued testing, I can’t get it back to virtualmin until I get home and make the firewall changes. (I can log into virtualmin but not my firewall remotely)

thanks for all who’s trying to help, I really appreciate the efforts and will put the virtualmin back live once I get home.

I even get this if I just try and browse to http://72.10.144.186

You shouldn’t expect good things to happen hitting IP addresses. Virtualmin is for name-based virtual hosting. Hitting the IP directly is undefined in a Virtualmin system–it’ll be whatever your Apache configuration wants it to be (probably the first defined virtual server). I just want to disabuse you of the notion that hitting the IP is a useful troubleshooting tactic. :wink:

OK, so have you gone through the Troubleshooting Common Problems guide?

http://www.virtualmin.com/documentation/id,troubleshooting_common_problems/#website

We’re going to need to see actual errors from the log (a browser error isn’t very informative).

Thanks for the tip Joe, and yes I’ve gone through the common problems as well as read alot of other posts but couldn’t find any pertaining to my exact issue, once I’m home (in about 2 hours) I’ll gladly send the errors from the log and switch back to virtualmin server as live.

thanks again

Derek

Well problem solved, cause: not enough coffee. After reverifying I had for some reason 2 public_html folders and I was setting permissions on wrong one… really can’t believe I didn’t notice last night :frowning:

I do apologize to those who have tried to help me, knowing result was such a simple mistake on my part… Thank-you.

DF

now you need to fix your 2 nameservers and hostname… :slight_smile:

Same here. I had to set appropriate permissions on the folder ‘public_html’ to install Drupal. This folder is located under:
/home/yourdomainnamehere/public_html

Find attached screenshot to clarify.

I wrote a how-to handbook at http://ubuntuforums.org/showthread.php?t=1197883
It covers installing Virtualmin, Webmin & Usermin on Ubuntu Server 8.04 LTS.