Ubuntu 14.10 + VMin 4.10 = Wrong Vhost?


after upgrading from Ubuntu 12 to 14 and bringing VMin to latest version i have a strange thing:

every time a add a new subserver, the vhost config file in /etc/apache2/sites-enabled/ is created like this:

But of course it should be created like this:

(where x is the v4/6 IP)

I’ve checked DNS binding and more but can’t figure out why this easy feature does not work anymore. I really need it a lot!

Any suggestions?


It sounds like that may be due to either having a NameVirtualHost line in /etc/apache2/apache2.conf which looks like “NameVirtualHost *:80”, or that there’s another VirtualHost in /etc/apache2/sites-enabled/ using “VirtualHost *:80”, quite possible a default file names 000-default.

If you see a 000-default file, you can just remove it. If you see a “NameVirtualHost *:80” , you can comment that out.


Or, there WAS a file 000-default, deleted, but still: new subservers are still being v-configured to *.80, and not to the correct IP…

More suggestions?