Trouble Installing Google Analytics Module

When I attempt to install wbm-virtualmin-google-analytics-1.9-1.noarch.rpm I receive the following message. This is tellingme that I need virtual server which I thought was apart of the core. Please help.

Failed to install uploaded module : RPM install failed : warning: /tmp/.webmin/wbm-virtualmin-google-analytics-1.9-1.noarch.rpm: V3 DSA signature: NOKEY, key ID a0bdbcf9 error: Failed dependencies: wbm-virtual-server is needed by wbm-virtualmin-google-analytics-1.9-1.noarch

Mmm… how did you do your Virtualmin install, and is it Pro or GPL?

Also, what does this show:

rpm -qa | grep virtual-server

Thanks!
-Eric

Virtualmin installation was originally from an rpm back around version 3.42 and upgraded to Pro at version 3.47 or sooner. Virtualmin has been upgraded without incident until this last upgrade when we got the announcement that there was a configuration check needed. suexec was/is misconfigured.

Executing rpm -qa | grep virtual-server
returns nothing.

Thanks for the help.

Okay.

It sounds like the Google Analytics module is expecting things to be installed one way, and they’re installed another.

I’m not sure of the best way to resolve that – I think I might recommend putting a request into the bug tracker, and getting their thoughts on the matter.

Just mention all the goodies you mentioned here.

Thanks,
-Eric

Virtualmin installation was originally from an rpm back around version 3.42 and upgraded to Pro at version 3.47 or sooner. Virtualmin has been upgraded without incident until this last upgrade when we got the announcement that there was a configuration check needed. suexec was/is misconfigured.

So you’ve obviously not been using suexec, so you won’t miss it when it’s gone. Disable suexec in your Server Template(s) in the Apache Website section. You can’t use suexec, if your suexec_docroot doesn’t point to the location of your virtual servers (usually, and we recommend, /home).

And since rpm doesn’t know about your virtual-server module…it can’t consider it present when checking dependencies. It’s usually safe to upgrade via RPM on a .wbm installation…I’m not sure if the GPL package allows overwrites, but you could give it a try. Download the RPM and install it:

rpm -Uvh wbm-virtual-server-X.XX-X.noarch.rpm

If it complains, let us know the error, and I’ll think about whether it’s going to do any damage to skip the scripts (that would probably be the source of trouble).

Or, you could stick with non-RPM module packages (wbm) and install google-analytics via that method. It still does dependency checking, but it does it against the Webmin module list, instead.

Thanks for the instruction.

I installed the rpm package for the virtual server and it is now listed under Webmin : System : Virtualmin Package Updates : Everything.

I installed the rpm package for the google-analytics with no complications; however, when I try to enable Virtualmin Analytics through Virtualmin : System Settings : Features and Plugins, I get the following error

[ul]"Failed to save enabled features : The plugin Analytics Tracking cannot be used : The Apache2::Filter Perl module is not installed. Maybe mod_perl is not installed on your system, or it is not version 2?"[/ul]

I’ll check that the Apache2::Filter Perl module is installed. mod_perl 2.0 is installed on the system.