Trim and trim-weekly services. Cannot disable in Bootup / Shutdown

I’ve just looked into building a server using f2fs. I’m using f2fs on all SSDs. The only partition I left as ext4 was boot. (It was a bit of a pain doing it all but I succeed and then successfully installed Virtualmin through the script.)

Now the “However”.

On reading up on f2fs and trim, via fstab the built in trim code is turned on automatically (it can be disabled). From what I understood, it’s a better implementation than the “continuous” trim. It stores blocks to be trimmed in memory and then cleans them up during idle time.

This being the case, I wanted to disable the fstrim.service and fstrim.timer … but neither will allow me to disable at boot using the bootup / shutdown page.

Any thoughts on a workaround?

Kind Regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.