Transfer virtual server chooses wrong user group

Hello everybody,

I have a problem with transferring a virtual server. The process fails with this error message:

Re-creating virtual server xxx.xxxxxx.xxx ..
.. a clash was detected : A unix group with GID 1002 already exists

Restore failed!

This is my second attempt to transfer the server. On my first attempt I got this error as well (GID 1004 is the source GID), so I changed the GID of the according group on the destination server from 1004 to 1099. But the transfer won’t finish. For some reason Virtualmin now chooses GID 1002 instead of 1004. I don’t want to mess with the GIDs as unlike 1004 the GID 1002 belongs to an important user/group and I don’t dare to change anything.

Here’s the details of both machines:

Source server:
Ubuntu 20.04.04, Kernel 5.4.0-122-generic
Webmin 1.999
Virtualmin 7.1-1 Pro

Destination server:
Ubuntu 20.04.04, Kernel 5.4.0-121-generic
Webmin 1.999
Virtualmin 7.1-1 Pro

Any help is greatly appreciated!

Nevermind. I tried to change the source GID from 1002 to 1004, but still no luck. I transferred the content manually. This thread may get closed.

Hello,

Can you please specify which page exactly did you use to transfer a virtual server?

I have just tried to restore a virtual server with an obvious UID and GID clashes using System ⇾ Users and Groups: Restore Virtual Servers page and it was re-allocated correctly.

Are you sure that the domain didn’t exists on the system before restoring it?