Total Newbie Help - Emails

have purchased my first vps through and set up first site ok but getting nowhere with emails

am confident that i’ve set up the email address correctly on virtualmin but i’m not entirely sure about DNS settings or if i need to do anything else on virtualmin ?

On the domains DNS settings i currently have the MX set to point to and have MAIL set to point to the vps IP address correctly (but maybe i should have MX set to the VPS server name instead ???)

i get this error message when trying to send to the email address - Sorry, I couldn’t find a mail exchanger or IP address. (#5.4.4)

and i get a No Socket error when trying to receive emails

thanks for any advice

Well, is your domain name using your Virtualmin server as it’s nameserver? Or is it using another DNS server?

If it’s using another DNS server, you may want to make sure you have all the DNS records pointing at your server.

I would also go over to something like, and run your domain name through that to have it verify that things look good.



all seems ok and strangely i have now started to receive emails into the server ok and no longer getting bounced error messages - could there have been a time delay or something?

so just this last problem of getting outlook express to connect to the server - from what i understand it seems to find the server ok but can’t connect:

The connection to the server has failed. Account: ‘Gleneve’, Server: ‘’, Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E

is there anything in Virtualmin that i need to adjust that might prevent a connection?


Well, there’s nothing you should have to do, it should all just work, in theory :slight_smile:

I might verify that Dovecot is running – you can do so with:

/etc/init.d/dovecot restart

Dovecot is your POP/IMAP server, and that appears to be what you’re having trouble with at the moment.


have restarted dovecot and also the firewall just in case, but still getting no connection and just the same error message as above

telnet just says connect failed on either port although a ping test to the same mail server address works perfectly so presumeably something on the server must be preventing outlook express’s connection ???

is there any way to find out what might be happening?

i can’t see anything in the logs at all and have tried every possible thing i can think of with no change to the problem at all which makes me think it must be something really simple that i’m missing!

it seems as if port 110 is closed - how do i open it on the vps firewall?

seem to have fixed it by executing:

iptables -A INPUT -p tcp --dport 110 -j ACCEPT

no i just need to figure out the username structure as it’s rejecting that now…

Well, I’m glad you got that far.

You can take a peek in the logs in /var/log (which one exactly depends on your distro) to get an idea of why it’s failing.

However, the username structure should be listed when you log into Virtualmin, select the domain in question from the dropdown, then go into Edit Mail and FTP users.

From there, it should give you the IMAP login name to use for each of the users.


thanks Eric, i think i’m almost there now, just this one final problem with plaintext error below - i searched the forum and the solution appeared to be to change the Dovecot config
to disable_plaintext_auth = no which I’ve done now, restarted dovecot and checked that it’s still there ok, but I’m still getting the same error message from outlook express -

Protocol: POP3, Server Response: ‘-ERR Plaintext authentication disallowed on non-secure connections.’, Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC91

any ideas?

You can fix that by editing /etc/dovecot/dovecot.conf, and setting disable_plaintext_auth to “no”, and then restart Dovecot with:

/etc/init.d/dovecot restart

Thanks but I’ve already done that and it shows up as below - is there anything else I can try or anything wrong with the following settings?

1.0.10: /etc/dovecot/dovecot.conf

log_timestamp: %Y-%m-%d %H:%M:%S
protocols: pop3
disable_plaintext_auth: no
login_dir: /var/run/dovecot/login
login_executable: /usr/lib/dovecot/pop3-login
mail_privileged_group: mail
mail_location: maildir:~/Maildir
mail_executable: /usr/lib/dovecot/pop3
mail_plugin_dir: /usr/lib/dovecot/modules/pop3
pop3_uidl_format: %08Xu%08Xv
auth default:
driver: pam
driver: passwd

well that’s weird i restarted again for the 3rd time and it’s all working now!

for the username, in case any other newbies have similar problems, on my set up it’s mail.mainusername for a mail@ email address