/tmp is mounted as noexec - workaround?

Trying to run the Virtualmin GPL script but due to /tmp being mounted as noexec it won’t run.

RATHER than me finding the commands to unmount / remount the directory… can I just cheat and change the install.sh to point to a different local path and safely delete said “tmp” directory after the script is done?

IE: /home/gpltmp

I found where to change it in the script, do I just have to change 1 single line for it to work?

Ah bugger it, spent time finding out how to remount it easily.

Simply

mount -o remount,exec /tmp

run the script

mount -o remount /tmp

So that it loads the settings from fstab!! :smiley: