"This site can’t be reached" after cpanel migration

I have used the Migration form to move a cpanel backup to my new Ubuntu 16.04 VPS with a fresh Virtualmin install on it. The migration successfully completed. In the cpanel backup, there was a main (empty) domain and 7 addon domains with a simple Wordpress site installed on each.

I went ahead and changed the VPS IP for my main domain in Cloudflare’s dashboard, and changed the VPS IP for one of the addon domains, waited a few minutes, refreshed my addon domain main page, and got the error

"This site can’t be reached refused to connect. ERR_CONNECTION_REFUSED"

Did I forget a step in the migration?

[Edit: searching more, I see in Server Status that Apache is not running, and nothing happens when I click on the green arrow to start it. Running sudo service apache2 restart gives

Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code. See “systemctl status apache2.service” and “journalctl -xe” for details.

and running systemctl status apache2.service gives

* The apache2 configtest failed. Output of config test was: AH00526: Syntax error on line 226 of /etc/apache2/apache2.conf: SSLProtocol: Illegal protocol 'TLSv1.1,' Action 'configtest' failed. The Apache error log may have more information. systemd[1]: apache2.service: Control process exited, code=exited status=1 systemd[1]: Failed to start LSB: Apache2 web server. systemd[1]: apache2.service: Unit entered failed state. systemd[1]: apache2.service: Failed with result 'exit-code'.

OK so it turned out that because I’m a newbie I decided to follow this tutorial to set up my vps https://www.mckerracher.net/vps , and in this tutorial we are adviced to add a bunch of lines to apache2.conf, notably this one: SSLProtocol TLSv1.1, TLSv1.2

I removed it and it’s now working fine. I’m closing this issue, am I missing somewhere a tutorial to secure my server with virtualmin (disable root access, etc.) or should I consider the default options are secure enough?

That ssl error just shows a syntax error. Not a “not working” error. You can restrict it SSL 1.2 or whatever you want. Caps, or period or something could be wrong. NOTE the error in quotes. Illegal protocol ‘TLSv1.1,’. See that comma after 1.1 but in the quotes. Means the syntax of whats is quotes ’ ’ is wrong. Remove the comma and use a space between then TLS versions.