There could be problems with postfix virtualmin spf and sending mails in spam or rejected

Sorry not updated virtualmin 6.05… (while still not knowing about status mariadb, phpfpm and some network problems in updates) the security flaw parts updated / renamed

CENTOS latest 7.7 and static ip’s ipv4 and ipv6

There not having dns in virtualmin for hostname and domains ( external)
UNPREDICTABLE results sending out mails or forwarding which ip is used. Somtimes ipv4 hostname shared which is ok.
Then several diferent ipv6 static for domains not the same as sending domain or hostname.

So then SPF record is wrong same is ptr record for helo hostname.

BOUNCES, REJECTS or in spamfolder are unpredictable results even on same receiving mail server / recipients.

So take care if some having same kind of problems.
Take a Look at the emailheaders from several mails for having this according settings if not workarround for spf is to get those ipv6 block to in the spf records.

Forward-Confirmed-ReverseDNS: Reverse and forward lookup success on ipipipipip -10 Spam score
SPFCheck: Server passes SPF test, -30 Spam score

and not for same forward to same recipient only other time having this.
0.0 SPF_HELO_FAIL SPF: HELO does not match SPF record (fail)
[SPF failed

So don’t know this is an issue while we have n’t the latest updates, if using external dns / nameservers in combination with ipv4 and ipv6.

Other should check if having mailproblems mailheader at receiver side for that.

Could this occure while no default ipv6 adress which matches the detected external address. is set for virtualmin? ( how and where can you do that while recheck gives no error)
ONly for ipv4 a default and shared
For ipv6 only the shared ipv6 and not a one which matches the detected external address.

Default IPv4 address for virtual servers is “ipv4…”
Default IPv6 address for virtual servers is “the ipv6.”
Default IP address is set to “ipv4…”, which matches the detected external address.

Possible solution workarround could be using.

The other new parameter is smtp_bind_address6. This sets the local interface address for outgoing IPv6 SMTP connections, just like the smtp_bind_address parameter does for IPv4:

    smtp_bind_address6 =

For me solved!