The way usermin/virtualmin handles user names

Hi, so let’s say I have a user with the email address

Virtualmin creates the user with the login : firstname.lastname.domain

Now, if I go to usermin to send an email, the from field looks like this : firstname.lastname.domain@localhost.

How can I setup… what?.. the server? Postfix? Virtualmin? Usermin? Anything? I mean… I would like the from field to be


Usermin is mis-configured on your box. I’m guessing it was installed before the installer got this right.

The instructions for fixing it are in the troubleshooting docs here:,troubleshooting_common_problems/#usermin_webmail_sends_with_incorrect_fromaddress

BTW-This is a client-side issue, so if you have similar problems with other mail clients, the right solution is usually in the client. Postfix can be configured to perform canonical map translation on these email addresses, if the client isn’t smart enough to set the From: address correctly automatically. I seem to recall we added an option in Virtualmin to auto-generate these maps, but I’m not seeing it at the moment.

btw I’m trying squirrelmail as well. Is there a way to configure squirrelmail so it uses the from field in the virtualmin format? btw what is the virtualmin user format? Realname and password is in passwd file… but and email?


Ok I found a way, see here :