The connection was interrupted

Hi,

I just installed virtualmin using the ‘install.sh’ script. Everything went well during the installation.

But I can’t access it using “https://‘ip’:10000/”. I get “The connection was interrupted” in firefox. I have a local server with virtualmin and it is working well.

I did:
nc -zvw 3 ‘ip’ 10000

and got:
‘ip’: inverse host lookup failed: Unknown host
(UNKNOWN) [‘ip’] 10000 (webmin) : Connection timed out

The firewall settings looked ok:
iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT udp – anywhere anywhere udp dpt:domain
ACCEPT tcp – anywhere anywhere tcp dpt:20000
ACCEPT tcp – anywhere anywhere tcp dpt:webmin
ACCEPT tcp – anywhere anywhere tcp dpt:https
ACCEPT tcp – anywhere anywhere tcp dpt:www

Not sure what to do.

Howdy,

Are you using a VPS? If so, is it by chance OpenVZ?

One thing you may want to try is just giving Webmin a restart… you can do that by running this command:

/etc/init.d/webmin restart

After that, are you able to access it?

-Eric

Thanks.

No VPS. It is a dedicated server with Debian Squeeze.

Restart did not help.

I searched a lot and could not find anything. Anyone can help?

Well, it’s tough to say what’s happening… and that’s certainly not a normal problem. If you post your server’s IP address, I could see if I’m able to access it. That would show if it’s a client-side issue, or a server-side issue.

-Eric

I tried from another computer at work and got a similar problem with a different message.

I also tried from the command line of the server itself:
wget https://IP:10000

and got this:
–2013-01-11 15:13:34-- https://IP:10000/
Connecting to IP:10000… connected.
ERROR: cannot verify IP’s certificate, issued by “/O=Webmin Webserver on …:
Self-signed certificate encountered.
ERROR: certificate common name “*” doesn’t match requested host name “IP”.
To connect to IP insecurely, use ‘–no-check-certificate’.

Like Eric said, you’d need to tell us the IP address, so we can test access from the outside for ourselves. Anything I could think of (local firewall, external firewall/router, Webmin not running) has alread been said.

Can you give me an email address to send it to? I don’t like the idea of telling the whole world about my server IP.

If it helps, I did a port scan and got this result:
Host is up (0.080s latency).
Not shown: 982 closed ports
PORT STATE SERVICE
21/tcp open ftp
25/tcp filtered smtp
53/tcp open domain
80/tcp open http
110/tcp open pop3
111/tcp open rpcbind
135/tcp filtered msrpc
139/tcp filtered netbios-ssn
143/tcp open imap
443/tcp open https
445/tcp filtered microsoft-ds
587/tcp open submission
777/tcp open multiling-http
993/tcp open imaps
995/tcp open pop3s
4444/tcp filtered krb524
10000/tcp filtered snet-sensor-mgmt
20000/tcp open dnp

Nmap done: 1 IP address (1 host up) scanned in 4.89 seconds

Not sure why but even with no firewall (iptables) I could not access virtualmin but after changing the port number it works now.

At least I learned a ton of new commands in that wasteful period! :slight_smile:

Hi,

We had a similar issue where the default port of “10000” was being blocked somewhere between our ISP and the server. At the time, we changed the port and the issue went away.

Good to see you solved the problem :slight_smile:

-Peter