The ClamAV program clamscan does not appear to be working properly .. your system is not ready for use by Virtualmin

I’ve just installed VirtualMin on a fresh Digital Ocean droplet, but I’m get this error when checking configurations:

The ClamAV program clamscan does not appear to be working properly :

. Either change the program on the spam and virus scanners page, or disable this feature.
… your system is not ready for use by Virtualmin.

The thing is is that I didn’t enable ClamAV or SpamAssassin because I don’t plan on using this server for emails.

I thought maybe it was a memory issue so I created a swap on my server.

I’ve tried enabling ClamAV, but for some reason it doesn’t want to enable.

How do I solve this?


If you aren’t looking to use email, you could always disable the ClamAV feature.

To do that, you can go into System Settings -> Features and Plugins, and in there, you can uncheck the “Virus Filtering” feature.

If you don’t need SpamAssassin, you could always disable the “Spam Filtering” option as well.


For some reason, today I checked configurations again and it is working now. Don’t know what I did?

I unchecked Virus Filtering and Spam Filtering as well as you said, but that was after the fact. The installation is working with them checked or unchecked.

I did receive this warning though:

“Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.”

Does checking the “Trust links from unknown referrers” solve this warning?

I haven’t created any virtual servers yet either.

I’m glad to hear that you resolved the ClamAV issue!

Regarding the other error that you mentioned – it’s an ipv6 issue, it’s not related to trusted links or referrers.

Are you using ipv6 on your server?


I’m not sure if I’m using ipv6 on my server.

So far the only thing I’ve installed is VirtualMin and everything that comes with it on a fresh Ubuntu 12.0.4 server.

Everything seems to be working so far now, so I’m not sure of the implications of that warning, which is why I was asking. I’m trying to future proof this installation as much as possible.


If you aren’t planning on using IPv6 at all, you can safely ignore that warning message.

If one day, you wish to use IPv6 – once you setup IPv6 addresses, you can then go into the Network Settings that the warning referenced in order to configure the default IPv6 address to use.