Technical Question about VM

Guys, I have a question I’ve been trying to find an answer to. Is there a way to install VM onto a sub-domain on Centos 7 with SSH?.. If I use wget http://software.virtualmin.com/gpl/scripts/install.sh, I don’t see a way to point it to a sub. I have another application set up on the main domain and it was installed via distro. I need to edit some of the files and I figure the only way would be to install VM to make it easier. Thanks in advance.

SYSTEM INFORMATION
OS type and version: CENTOS 7
Webmin version: REQUIRED
Virtualmin version: REQUIRED
Related products version: RECOMMENDED

Actually, can I install on a directory?

Why on earth would you ever do that? It makes no sense at all. I don’t even think it’s remotely possible.

What is the other “app”? I run Virtualmin and Plex Media Server on the same server with no issues at all. In fact, it’s easier because Virtualmin automatically updates Plex and the System OS saving me time.

I’m trying to edit files in Freepbx… It was installed with a Distro and I can’t find a way to do them. I don’t want to go through SSH… I tried installing Desktop and it didn’t work either…

That doesn’t make sense on a couple of fronts.

Virtualmin is a system service that needs root access to the system to do its job. It is not a “web app” in the sense of running under a web server. You don’t install Virtualmin “into a subdomain” because it doesn’t run in your web server…it manages your web server.

And, a subdomain is just a name. Virtualmin can listen on the IP that a subdomain name points to (by default, Virtualmin listens on all addresses, so if you have a subdomain name pointed at your Virtualmin server, Virtualmin will answer).

It also doesn’t make sense to install Virtualmin “on a directory”. Virtualmin, again, is a management tool. The dependency list includes thousands of files., and a dozen other system services. Virtualmin is not a web app, it’s a management tool, and it needs administrative access to all of the services it manages.

In short: Virtualmin doesn’t run under the web server.

The File Manager (with text editor) is a Webmin feature. It is not exclusive to Virtualmin. Maybe you just want Webmin? You can’t install it on a subdomain or in a directory either, but it’s a much simpler thing to install on an existing production system. It won’t disrupt anything and does not need a freshly installed OS.

That settles that… LOL… Thanks Joe…