System Time - No Tabs

My System Time in Webmin no longer shows anything under the tabs “Change Time Zone” or “Time Server Sync”. Used to be just fine. “Set Time” tab still shows up but there is now an error that appears:

hwclock failed :

hwclock --debug shows:

[root@ns1 ~]# hwclock --debug
hwclock from util-linux-2.13-pre7
hwclock: Open of /dev/rtc failed, errno=19: No such device.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

What cold have changed? Where do I look?


Seeing this in miniserv.error log:

Error: hwclock failed :

Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.

Started after yum update of:


Well, I might recommend filing a bug report. It’s possible that some things are occurring automatically now, and may not be working as expected :slight_smile:

In some digging on Google though, I ran into two thoughts on the matter:

  1. This issue seems to be more likely to occur on a VPS, where one might not have access to the actual hardware clock.

  2. If you’re on a Xen-based VPS, it may be possible to resolve that problem by running this as the root user:

echo “1” > /proc/sys/xen/independent_wallclock

Please note that I got the above from another forum, and have not tried it myself, so I can’t verify what it does or how it will affect your system :slight_smile:


I don’t use a VPS server. I did just install ntpd on my CentOS 5.3 box and it seems to be working fine in that dovecot is not shutting down due to time moving backwards.

Do you still recommend I file a bug report?

Yeah, in that case, I’d recommend filing a bug report – Jamie should be able to help figure out what’s going on :slight_smile: