System Logs otpion not showing on Redhat enterprise 6.3

Hello all,

I’ve installed virtualmin in a RedHat enterprise 6.3. I have log_erros enabled on PHP but the errors don’t show on Apache Error Log, as it does on my other servers.

When I click on “return to system logs” on the apache error log page, I get a message:

The syslog configuration file /etc/syslog.conf was not found on your system. Maybe syslog is not installed, or a newer version like syslog-ng is in use, or the module configuration is incorrect.

On webmin–>System, I don’t have the “System Logs” option as I do on my other servers.

What can I do?

Thank you

-Rogerio

Howdy,

Are you looking for the error logs for a particular domain?

If so, those are stored in $HOME/logs/error_log – which is accessible from within Virtualmin by going to Logs and Reports -> Apache Error Log.

-Eric

Hi Eric,

Yes, that’s the one.

The problem is PHP errors don’t show there, as it shows on my other virtualmin boxes.
It works ok on Centos, but not RedHat. I have 2 Redhat instalations with the same problem.

What can I do?

Thanks

Hmm, I’ve never heard of the errors not going to the error log for that Virtual Server.

Where are you seeing the errors? Are they going to the main Apache log, /var/log/httpd/error_log?

-Eric

Hi Eric,

Sorry, my mistake. We are developing a few joomla modules, and on those files the error are not shown. But on a regular PHP file the errors are logged correctly. So I’m gonna check why the errors are not logged using Joomla.

And how do I enable the System Logs option on Webmin->System? That option does not show for me on the RedHat Installs.

Thanks

  • Rogerio

If you look in Webmin -> Un-Used Modules, do you see System Logs mentioned in there?

-Eric

I have System Logs, and System Logs NG. When I click on them I get the following messages:

System Logs: The syslog configuration file /etc/syslog.conf was not found on your system. Maybe syslog is not installed, or a newer version like syslog-ng is in use, or the module configuration is incorrect.

System Logs NG: The system logging daemon syslog-ng was not found on your system, or is not the syslog-ng program. Adjust the module configuration to use the correct path.

Thanks

  • Rogerio

Well, I don’t have a RHEL system to test on, but it sounds like the logging facility used by RHEL is somehow not being detected by default.

One thing you may want to try is to go into the “System Logs” in the Un-Used module section, click on Module Config -> System Configuration, and to make sure that “Path to syslog config file” is set to “/etc/rsyslog.conf”.

-Eric

Hi Eric,

Changing the path to /etc/rsyslog.conf worked! It was /etc/syslog.conf.

Now how do I make the “System Logs” appear on the Webmin->System menu?

Thank you!

  • Rogerio

If that doesn’t happen automatically, then you may need to click “Refresh Modules” on the bottom of the menu on the left.

-Eric

Refreshing the modules worked!

Thank you very much,

-Rogerio

Grateful for this 4 yrs later. Many thanks.