System logs module -can't edit or delete

I have added several log files to the System Logs module but I am unable to edit or delete any that I have added. The default ones are linked (blue) so those can be altered but any of the new ones I added are not linked and I have no access to edit or delete them. I have full access to the module so I am stuck. Is there a way to remove these entries manually? The Webmin instructions I found say to select the destination and alter them that way. This is not possible with the ones that don’t have links.

Hello @ksihota.

You have added several log files to the System Logs. What are the settings and paths you have applied to add log files to the System Logs?

That doesn’t sound right. The only logs you can’t remove/edit should be logs provided by other modules. There’s a config option to not show them Show logs from other modules?. If you added them in the module config, those also won’t be editable, but can be removed in the Module Configuration, where they were added.

Edit: The UI here is maybe confusing. I’d forgotten how it worked, too…so I’ve updated this comment to more accurately reflect how it works.

Webmin/System/System Logs
I added the path to the existing log and then I can select view to see the log. I can’t edit or delete these. Where can I do that?
Not sure but maybe the first 5 in yellow are preset (I thought I had created them a long time ago)
The lfd.log (last one) is just added as an extra log and I can remove it.


Visibility of those logs can be edited in module’s configuration (cog icon in top left).

Uncheck an option Show logs from other modules and arbitrary logs you would want to appear in System Logs module can be put to Other log files to show textbox.

1 Like

Obviously I didn’t put those logs in (unless I did it from another module.) Trying to remember changes made months previously is not easy.

It would be nice to have a field on the main screen showing which module is providing the log, or maybe a link to take you to the module if you click on the specified log.

I realized that using the other option (adding logs in the list field) is all I really needed.

Thanks again for your clarification


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.