System Information - does not work

I have a new problem:

In Webmin “System Information” does not work. I have the menu on the left, but the right stays white, except the “Configure this page | Refresh system information | Virtualmin documentation” script.

Any idea what it could be?

Are you seeing any errors in /var/webmin/miniserv.error?

-Eric

I have plenty (100+) of those:

Failed to initialize SSL connection

I just did some googling, so far no clue…

Okay, I doubt those SSL errors are the issue here.

Can you post a screenshot of what you see when going to that screen?

And what browser are you using?

-Eric

I attached the screen. This could be a key to the SSL errors.:

[08/Jan/2009:07:22:32 -0600] miniserv.pl started
[08/Jan/2009:07:22:32 -0600] Perl module Authen::PAM needed for PAM is not installed : Can’t locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec/webmin /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 10) line 1.
BEGIN failed–compilation aborted at (eval 10) line 1.

Failed to initialize SSL connection

While I’m open to the idea, it’s unlikely those errors you’re seeing in the logs are related to the problem you’re having now with the one screen.

The SSL errors are probably from people (or bots) connecting to Webmin without using SSL. The PAM error is common (I get it on my system), and simply means you have to use users that are in /etc/passwd. Which just about everyone does anyway, so no big deal.

Now, as to why your System Info screen is acting up… that’s a bit of a mystery :slight_smile:

I suppose I’m curious what happens if you log out of Virtualmin, restart the daemon (/etc/init.d/webmin restart), and then log back in – does that help?

-Eric

I did a /etc/init.d/webmin restart - but didn’t expect it to change anything since I also have (had) the problem that webmin/usermin was often stalling (a few times a day). A few weeks ago I installed Monit and the programs Autostart now. Webmin gets autostarted by Monit in average 5 times day. Usermin autostarts seldom, maybe twice a week.

When I do a Yum update in putty it hangs there I need to force close putty.

For “Failed to initialize SSL connection”, I didn’t count them, but I think I get a few 100 (maybe over 1000) a day.

yum update is unrelated to webmin so there might be something else going on on your box.

Questions I would ask myself
Is this a vps? How much ram does the box have? Is DNS correct, has it a FQDN working properly? Did you install with the install.sh? Are you sure there is no faulty hardware?

Is this a vps? - Yes.

How much ram does the box have? - 296Mb

Is DNS correct, has it a FQDN working properly? - I am not sure. I have one IP, and 6 or so domains that share that IP. I had to look up what FQDN means, and I am not sure. I think my VPS host uses Confixx and I remember I had to let all domains end with a dot.

Did you install with the install.sh? - Yes

Are you sure there is no faulty hardware? - No, as I don’t run the hardware.

I presume something messed up some software on the VPS. No with 6 domains I am a bit scared of whiping it and doing a fresh install.

ssh into the box and type: hostname this will reveal the hostname

296mb isn’t much but should be okay, I have a working vps with 256mb. Check Virtualmin - System Settings - Module Config, that Preload Virtualmin libraries at startup? is set to Core only.

Is this Centos? Cause Yum takes a lot of RAM and probably won’t allow you to properly update the system. If you want to run any updates in Yum,
you’re best off the stop Bind/Postfix/Dovecot/MySQL and even Apache temporarily during Yum updates and
to install the Perl module Authen::PAM with yum install perl-Authen-PAM

Use apt-get if on debian based

Hostname is: vps-#######-###.cp.myVPShost.com (not the real name, but something like that)

My system setting is:

Preload Virtualmin libraries at startup? - No (I guess that’s the most memory friendly already, or?)

It’s CentOS5.2

Cause Yum takes a lot of RAM

I was fiddling with the VPS now and it crashed. Even TOP got kicked out. After that many modules were down. TOP worked again and memory use was only 38Mb. I tried a YUM then - and - it worked! I did “YUM update” and 240Mb of data got downloaded.

After stat I started webmin and I got again the “System Information” screen with available updates. I did first Usermin (from 1.40 > 1.41), it hung in the end but updated.

Now YUM seems stuck with 30% memory use when I do TOP. YUM stays also when I log out of webmin.

Now I am back the “System Information” white screen.

after the update you’d have centos 5.3 and a reboot of the server is required.
Stop the services again and do another yum update.
See if another reboot is required, normally only if kernel headers are updated.
Check if Yum has no processes running, kill them otherwise.
then start webmin. Only run the services you really need. see that in webmin - System - Bootup and Shutdown

your white screen is likely cause due to low ram and you need to optimise the system. per haps 6 domains are too many depending what scripts are in there.

as for the hostname, this could be okay.
Virtualmin libraries to no is okay too, though I choose core only.