System and Server Status - monitors


I’m using Webmin that is coming together with Joyent’s accelerators. I used to setup monitors to check my services.

In the Webmin version 1.380 I could find them under Webmin->Others->System and Server Status, however with the newer machines we’ve got Webmin 1.410 and it’s not there anymore. I looked through all tabs and can’t find it.

I would appreciate any help. Thanks !


Hrm, I’m still seeing “System and Server Status” on my system here.

What happens if you click "Refresh Modules" on the bottom-left, does it show up then?

If not, do you by chance see it in Un-used modules?

Thanks for your reply.

This is strange. I don’t see any “Refresh Modules” link in my version. Neither “Un-used Modules”. I looked into “Webmin Configuration” and it’s listed under “Reassign Modules”, assigned to “Others”. I tried to change category but it’s not showing under any category set.

Joyent’s guys doesn’t support Webmin/Virtualmin and directed me to this forum.

This is running under:
Operating system Sun Solaris 11
Webmin version 1.410
Virtualmin version 3.56.gpl (GPL)

Thanks for any help.


Hrm, so when you log into Virtualmin, click “Webmin” on the top-left, you don’t see a “Refresh Modules” link on the bottom-left of the page?

Do you know what theme you’re using?

My theme was “Virtualmin Framed Theme” and I couldn’t see “Refresh…”. Once I changed it to “Blue …”, “Refresh Modules” link appeared.

I tried refreshing and it says :

"Checking for usable Webmin modules …
… found 67 with installed applications, 23 not installed."

However "System and server status" is still not there.

("Un-used Modules" appeared but does not include "System…")


Joyent historically provides a custom Webmin package…and it’s missing a bunch of modules. Maybe this is one of them?

I don’t know. It’s been a while since I’ve poked around on an accelerator.

Look in the webmin directory to see if a "status" directory exists…if not, you can use the Webmin Modules page to install it.

I can see “status” dir in the webmin directory. It’s also listed under “Webmin Configuration” -> “Reassign modules” under “Others” category.

However it’s not visible anywhere within the interface…