System and Server Status - False Positives

Many of our websites are getting messages such as:

Monitor on my.domain for ‘Website www.customer.com’ has detected that the service has gone down at date time

I see Webmin > Others > System and Server Status for ‘Website www.customer.com’ that has the entry:

Connection timeout * Default o ___ secs HTTP request method [HEAD]

I couldn’t find the place where the Default is specified. Does anyone know where to set the default?

While System and Server Status is a Webmin module, is it the case that the adding of the ‘Website www.[subdomain.]domain.tld’ is done by VirtualMin? If so, are there any controls or templates over how the entry gets created? For example, right now, my customers are being notified by e-mail when services “go down” (even though these seem to be false positives).

Any help on how to customize this so I don’t have to edit each new domain manually is appreciated.

I should mention that:

VirtualMin > System Settings > Server Templates > Default Settings > Status monitoring

as well as templates based on Default Settings have all of the entries grayed out when “None” is selected for Additional email address for monitoring messages. There doesn’t seem to be a way to change the entries on this page for the primary email address.

Again, maybe this info is elsewhere, but I haven’t found it yet.

i have too little time atm to really dig in however the "connection timeout"I have constantly with a server in the US monitored by the server in Europe.
To me that means the overseas connection is in the way but I can be wrong about that of course.

Another server I monitor I never have that issue with as it is in the same country as the server that monitors it. :confused:

Does anyone know how to set the timeout to be higher? The servers and customers are both in the US. I don’t know how the monitor is testing up time, but it is generating many false positives every day.

If there is no global control for setting the default, how do I turn this entire feature off? If it isn’t reliable, I don’t want to use it.

i dont know, per haps you can change the “Failures before reporting” value to 2 or 3.
Also we recently had a bad switch in the datacenter causing many false positives (which all went away after replacing it), so it is not to say indefinitely it’s because of the modules settings.

Hrm, I’m not sure that the fields you mentioned above should be grayed out purely because “Additional email address for monitoring messages” is set to “none”. I see the same behavior on my system, but I suspect that’s a bug.

I’d file that in the bug tracker so that they can correct it, you should be able to bump up the timeout without having to specify an additional email address.

Secondly, if you go into System Settings -> Features and Plugins, you’ll see Status Monitoring 2/3 of the way down. If you no longer want it enabled, you could disable it there.
-Eric

I’ve logged FS#4394 - Status Monitoring: Cannot set Defaults and Domain Overrides

http://www.virtualmin.com/index.php?option=com_flyspray&Itemid=82&show_task=4394

And, thanks for the reference to the Features and Plugins. I’ve unchecked Status Monitoring until this issue can be resolved. The customer complains/worries about their sites “being down” were just clogging up our support lines.