Support for Subversion 1.7

Currently Subversion version 1.6 is installed with Virtualmin. The current stable version of Subversion however is 1.7 and has a lot of improvements over earlier versions.

Is it possible to use Subversion 1.7? And if so, how?

Howdy,

Well, there shouldn’t be any sort of compatibility problem with subversion 1.7.

However, the package versions you have are what comes with your distribution. So the key would be to find a distribution that provides subversion 1.7.

Now that I look, it unfortunately appears new enough that CentOS, Debian, and Ubuntu are all offering subversion 1.6.

So if you really want to use subversion 1.7, you’d either have to build it yourself, or find someone who built a package of it for the distribution that you’re using.

-Eric

Thanks for the reply. Will look into manually installing a new version and report back.