SUEXEC problem

Hi all,

after search and applying all the tips (like reinstall) that I found in this forum (and others) I still have trouble with suexec. This is the output of it :

/usr/lib/apache2: ./suexec2 -V

-D AP_DOC_ROOT="/var/www"
-D AP_GID_MIN=100
-D AP_HTTPD_USER="www-data"
-D AP_LOG_EXEC="/var/log/apache2/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=100
-D AP_USERDIR_SUFFIX="public_html"

But shouldn’t it read -D AP_DOC_ROOT="/home" ?

I never got a suexec downloaded that fit that line. I am running :

Operating system Ubuntu Linux 6.06.1
Webmin version 1.401
Virtualmin version 3.52 (Pro)

Webmin/virualmin just updated thinking it might fix the issue, but it gave me the above suexec back.

Please help

Uwe

If you also enable the apache module "userdir" the /home/public_html which is the default location for VM websites it will work.

Hi sgrayban,

If you also enable the apache module "userdir" the /home/public_html which is the default location for VM websites it will work.

Thanks for your help!

It is enabled. And if I delete/move the installed suexec2 everything seems to work but there is no user switching (obviously) and I want to have that for more security.

Uwe

Try using apt-get to update apache2 (apt-get install apache2). For some reason that I’ve yet to determine apt-get will sometimes ignore our Apache package during installation. You may even have to force it to use our repository instead of the default.

Hi Joe,

thanks for pitching in.
I tried that, but it looks like its pulling it from here :
archive.ubuntu.com dapper-updates/main apache2 2.0.55-4ubuntu2.3

I tried forcing it by re-sorting sources.list but no luck. Any other idea to force it? And also, do I still need to uninstall apache2 before I try it again?

Thanks Uwe

Hi,

just to update and close the thread.

I ended up reinstalling the sever and also switching from ubuntu to centos. It installs fine, just a few little setup bugs here and there (postfix,dovecot) which were easy to handle in minutes.

Solved the problem and I have it now on a second vps.

Uwe

Hi Uwe,

could you please tell me what problems you had with Postfix and Dovecot? I’m failing to get my server to work correctly. CentOS 5.1, VM Pro.

Thanks

Gerald

Hi Gerald,

just post whats not working on your machine. One of the fixes I had to do is posted here : http://www.virtualmin.com/index.php?option=com_fireboard&Itemid=77&func=view&id=9640&catid=8#9640
Which fixes a dovcot problem I also had. In postfix the limits for mailbox size and message size were not set correctly giving error messages, easy fix.

Uwe

Uwe,

Thanks for your reply, but I got it to work myself.

All the best

Gerald