SuExec for Sub-Servers and Sub-Domains


Our server is setup to use SuExec, as well as FastCGI, for all our users. That in itself is working great. When a I create a new Virtual Server, the SuExec directive gets added, and things work like a champ.

The problem I’m having is in dealing with sub-servers and sub-domains. Basically the SuExec line isn’t being added in those two cases.

In the sub-server template, under the section “Directives and settings for new websites”, “Default” is the one that’s chosen, making me think that it’d be using what’s configured in the main Server Template (ie, adding the SuExec line).

It’s possible it could work if I instead chose “Apache directives below” instead of “Default”, and explicitely chose to enable “Automatically add appropriate SuExec directive” in the sub-server template (this is course is enabled in the main server template).

But I really like the idea of not having to duplicate all that data for each template, and it looks as if the idea is to "inherit" that information from the parent template.

I’m using Virtual Server version 3.12-1, and Virtualmin Release 1.0-1.rhel.

Is this a bug that I should be filing, or am I going about something the wrong way? :slight_smile:


2015… but same doubt here!

By default subserver template has “Automatically add appropriate SuExec directive?” to NO and “Apache directives below” selected instead “From Default”.

Can I ask why?

Directives below and Defaults are the same… so I think I’m going to selected “From Default”.

What about SuExec?


A newly installed Virtualmin system really should use suexec by default – that’s the only way that FCGID will work (which it also uses by default).

If that option is somehow disabled, I would recommend re-enabling it though.