Success with installtion PHP5 on Debian with Virtualmin?

Hi,
did anybody succeed with installing PHP5 (either instead or extra to PHP4) resulting in a working installation on Debian?
I succeeded with PHP5, but afterwards, mySQL was broken again…
I tried this: http://wiki.phpaction.de/index.php/Linux:debian-PHP4-PHP5
but this wasn’t successful. First problem when restarting the Apache2 server was a problem with php_value max_memory in the site config files. However, even after uncommenting it, the Apache2 was starting again, but without proper PHP support.
I needed to rollback installation to a working installation.

Any ideas?

Dirk

Upgrading to the latest release 3.35 of VirtualMin pro on Debian again throws an error:

require virtual-server/postinstall.pl failed :

Undefined subroutine &virtual_server::init_config called at /usr/share/webmin/virtual-server/virtual-server-lib.pl line 5.
Compilation failed in require at /usr/share/webmin/virtual-server/postinstall.pl line 3.

Dirk

sorry the post before should be an addition to another of my posts, please ignore…

I wanted to ask here regarding PHP5 and MySQL. When I try to install php5-mysql I receive the following dependency problems:
php5-mysql: Depends: libmysqlclient15off (>= 5.0.24-2) but it is not installable
Depends: php5-mysqli (= 5.1.2-1vm3.5) but it is not going to be installed

libmysqlclient15off is only available in debian unstable. Does it mean PHP5 is not ready yet for Debian 3.1?

Should I install libmysqlclient15off from unstable to get PHP5 with MySQL to work?

Dirk

Should I install libmysqlclient15off from unstable to get PHP5 with MySQL to work?

Dirk

Hi,
as written here: http://www.virtualmin.com/forums/message-view?message_id=36166
its the plan to have PHP5 running out of the box of Virtualmin Pro - at least thats what I understood. When will it be available for Debian?

regards dirk

Should I install libmysqlclient15off from unstable to get PHP5 with MySQL to work?

Dirk

Hi,
as written here: http://www.virtualmin.com/forums/message-view?message_id=36166
its the plan to have PHP5 running out of the box of Virtualmin Pro - at least thats what I understood. When will it be available for Debian?

regards dirk

Hey Dirk,

I have experimental php5 packages already in the Debian repo, and I believe mod_fcgid is available from Universe (those are the two pieces needed). You’re more than welcome to give it a try now (and we’ll help if anything blows up). Support in Virtualmin seems to be pretty good at this point for selecting between versions.

You’d use apt-get to install all of the php5 packages you want (the obvious list is php5, php5-mysql, php5-cgi, php5-cli, php5-gd, php5-pgsql, php5-xmlrpc), and mod_fcgid (assuming its available in universe–let me know if it’s not and I’ll try to make it available in our repo this week).

Once those are installed, make sure you’re running the latest webmin-virtual-server version, and then switch the PHP execution type for one or more domains to mod_fcgid (“FCGId (run as virtual server owner)” in the server templates or in the “Website options” for domains that already exist).

The Virtualmin support is thought to be working well (we aren’t getting any bug reports from the people who are using it). So this will all be getting setup during install in the next couple of releases of install.sh and the virtualmin-base package.

Should I install libmysqlclient15off from unstable to get PHP5 with MySQL to work?

Dirk

Hi,
as written here: http://www.virtualmin.com/forums/message-view?message_id=36166
its the plan to have PHP5 running out of the box of Virtualmin Pro - at least thats what I understood. When will it be available for Debian?

regards dirk

Hi Joe,
this is still pending, as far as I can see. When I try to install php5_mysql, the following dependencies are not met:

The following packages have unmet dependencies:
php5-mysql: Depends: libmysqlclient15off (>= 5.0.24-2) but it is not installable
Depends: php5-mysqli (= 5.1.2-1vm3.5) but it is not going to be installed

Is there an outlook, when PHP5 really will work out of the box?

Dirk

Hey Dirk,

I have experimental php5 packages already in the Debian repo, and I believe mod_fcgid is available from Universe (those are the two pieces needed). You’re more than welcome to give it a try now (and we’ll help if anything blows up). Support in Virtualmin seems to be pretty good at this point for selecting between versions.

You’d use apt-get to install all of the php5 packages you want (the obvious list is php5, php5-mysql, php5-cgi, php5-cli, php5-gd, php5-pgsql, php5-xmlrpc), and mod_fcgid (assuming its available in universe–let me know if it’s not and I’ll try to make it available in our repo this week).

Once those are installed, make sure you’re running the latest webmin-virtual-server version, and then switch the PHP execution type for one or more domains to mod_fcgid (“FCGId (run as virtual server owner)” in the server templates or in the “Website options” for domains that already exist).

The Virtualmin support is thought to be working well (we aren’t getting any bug reports from the people who are using it). So this will all be getting setup during install in the next couple of releases of install.sh and the virtualmin-base package.