Subversion strangeness

I am having a strange problem with Subversion on virtualmin.

I can create and commit to a repo fine but the commits fails unless I commit the parent folder first.

For example:

I have a structure like…

  • Folder
  • file1.html
  • file2.html
  • etc…

To get a successful commit, I need to commit the folder first and then commit the files, otherwise I get various errors (permanatly moved, unable to find server)

I am using the base subversion and mod_dav_svn

Here is my vhost config

<Location /svn>
DAV svn /etc/httpd/conf/httpd.conf (1150)
SVNParentPath /home/sitefolder/svn /etc/httpd/conf/httpd.conf (1151)
AuthType Basic /etc/httpd/conf/httpd.conf (1152)
AuthName local.sitefolder.co.uk /etc/httpd/conf/httpd.conf (1153)
AuthUserFile /home/sitefolder/etc/svn.basic.passwd /etc/httpd/conf/httpd.conf (1154)
Require valid-user /etc/httpd/conf/httpd.conf (1155)
AuthzSVNAccessFile /home/sitefolder/etc/svn-access.conf /etc/httpd/conf/httpd.conf (1156)
Satisfy Any /etc/httpd/conf/httpd.conf (1157)
</Location>

Any ideas gratefully accepted…

Mark

This actually sounds like normal SVN behaviour - you can’t add a file unless you have added the parent directory first. I don’t think you need to actually commit the directory though, just “svn add” it. Which should normally add all the files it contains too…

Yep, this is true but my problem is AFTER I have svn ‘added’…

P.S. It seems as though Apache is timing out…

I can commit all my files by commiting blocks at a time…

Ok, so it looks like this may really be a network issue. Check that you can ping your SVN server, and for any messages in the domain’s logs/error_log file.

I’d also check memory on the server–SVN can be a bit consuming, and it may be having to wait on swap long enough to cause timeouts.

Example: Have already added via SVN add then…

[… lots of other commits …]

Documents and Settings*\Desktop\SVN Repositories\host.domain.co.uk\library\Zend\Loader.php
Documents and Settings*
\Desktop\SVN Repositories\host.domain.co.uk\library\Zend\Locale\Data\sr_Latn_CS.xml
Documents and Settings*\Desktop\SVN Repositories\host.domain.co.uk\library\Zend\Soap\Server.php
Documents and Settings*
\Desktop\SVN Repositories\host.domain.co.uk\library\Zend\Locale\Data\es_AR.xml
Documents and Settings****************\Desktop\SVN Repositories\host.domain.co.uk\library\Zend\Mime\Decode.php
Commit failed (details follow):
PUT of
‘/svn/host.domain.co.uk/!svn/wrk/cdf7b59d-599f-904d-96ce-b2f16e2e01ce/library/Zend/Mime/Decode.php’:
could not connect to server (http://host.domain.co.uk)