Subserver proxy_pass fails with https

I have a website on and I had an alias on

I now have to have a separate email account for so I converted the alias to a subserver and then used “edit proxy website” to redirect all HTTP requests going to to actually load It works, except if someone uses,

What should my setup be for the https proxy redirects to work?

You have two possible approaches:

  1. in Virtualmin | Server Configuration | SSL Certificate | Lets Encrypt, manually add and to ‘Domain names listed here’ box and generate a SSL certificate which works for both domains.

  2. Don’t go the subserver route. Make an alias of as before; for email there is an option offered by Virtualmin at the time of creating a virtual server to create it as ‘alias of domain with own email’. See screenshot.

I went with options #2 - which I should have done to begin with, but I didn’t even see the option! Thank you for pointing this out! Virtualmin is so chock full of features, that it is hard to find them all.

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.